Jump to content
Flirc Forums

One Remote press, continued repeating Flirc commands


Recommended Posts

not quite sure what u mean by get stuck? With noise cancel on? Or the repeating keys?

Edit. I tried setting inter key delay 0 with noise cancelling, that didnt work very good. Also tried inter key delay 0 without noise cancel, which was even worse than inter key delay 5. So I tried setting inter key delay 7 with noise cancell off, and so far its been great. I hope it behaves now ;) By the way, whats new in firmware 3.7? Cant seem to find any patchnotes/changes anywhere?

Edited by nixpix
Link to comment
Share on other sites

  • 9 months later...
  • 1 month later...

I've been having the double press problem for months now and it's driving everyone mad!


Harmony 350 with default Flirc/Kodi profile.
3 more buttons programmed and added to keyboard.xml 
Fire TV


Only seems to happens with the back button which I believe maps to browser_back in the default harmony/flirc/kodi setup
Also replicate-able when the Flirc is plugged into my PC without Kodi - using multiple tabs in Notepad++ the back button cycles tabs twice on a single press.
If you tap the button VERY quick, the problem doesn't occur on either PC & N++ or FireTV & Kodi.

Things tried

Set the key delay in Flirc to both 0 and 7. 
Set Harmony repeat value to 0.
Re-installed Kodi 16 and 17.
Re-configured the Harmony
Upgraded Flirc Firmware

Edited by slikvik
Link to comment
Share on other sites

  • 2 months later...

Do we have any news on this at all?? It's driving me made and makes using Kodi (which is my main living room PVR) a frustrating experience.

I've tried all combinations and currently have Flirc at 7 and Harmony at 0. It's NOT Kodi on the Fire TV as it also does it on Windows outside of Kodi.

Link to comment
Share on other sites

  • 2 weeks later...

Hi There. Here I am again after 3 years. Reason it took so long is I gave up on using the Pi as a media centre back then but I returned to using it right now for the simple reason that they changed the TV signal to DVBT2 in my country and now I have very bad reception. So I took my Pi and Flirc out of the drawer and configured it to used ZattooBox over LibreElec.

So what happened is I first used my TV receiver remote by Phillips to control Kodi via Flirc. No problem whatsoever. But then I got rid of that receiver, so I decided to use my old Apple remote and that's where the trouble came back: endless, chaotic key repeats. Interestingly, the very first day, it worked like a charm. The problem only appeared on the second day and lingered on until now.

I tried the trick with the grounding cable as suggested in this thread:
...but that didn't change a thing.

I'm using a 1st gen Flirc (transparent enclosure) with latest Firmware version, a Pi version B and a 1st gen (white) Apple remote.

Link to comment
Share on other sites

Very frustrating for us at home as Kodi with PVR backend is my living room primary TV service. This problem only occurs on the back button but that button is used all the time so we're constantly having to give the button the quickest tap possible to stop it duplicating the key press and exiting kodi completely!

Actually I don't know if that helps in solving the problem but I can "fix" it by pressing the back button as quickly as possible. If you press it at a comfortable speed I get two instances of [browser_back].

Link to comment
Share on other sites

I have an update:

I can say that it's definitely that damned crApple remote. I don't know what it does but it's the only remote that causes such a stir. Just purchased a Minix remote and it works like a charm.

Sorry for not trying other remotes earlier – the thing is: I hardly have any and the few I have lack directional buttons so I didn't bother trying them out.

So there's that. Maybe it helps someone. The same Apple remote works fine with Apple products btw.

Link to comment
Share on other sites

  • 5 months later...
1 hour ago, ianevans said:

Ok, so I have a Harmony 300 remote. The MyHarmony software doesn't give me any options to change key repeats/delays for that model.

And when I fire up the Flirc software v 3.0.22, the advanced settings don't give me any option there either. So what do I need to do?


Can you post a screenshot?

Link to comment
Share on other sites

On 10/4/2017 at 11:46 AM, ianevans said:

Okay, after going to File-Advanced Settings, I did a screen capture. I'll also upload my config. Some of the button seem to behave but a few like the arrows, really go crazy and send about three commands. I've attached my config in case that's the issue. buster is my htpc.

flirc advanced.png


Uncheck the built-in profiles, let me know if that does anything. Also, what version of firmware are you on?

Link to comment
Share on other sites

  • 5 weeks later...

I'm having the same problem here now. Was using XBMC 13.2 and did not have the issue (or had it resolved there at least), but upgraded recently to Kodi 17.3 and the problem (re)occurred. I'm using a Harmony One remote set to emulate a Syabas PopcornHour C-200 device. Target computer is a Win 7 HomePremium laptop. Flirc firmware is 3.6.

Noise-Canceller is turned off, Inter-Key delay is set to 2, built-in profiles are enabled, sequence modifiers are disabled.

Let me know if there is any more information I can provide to assist with resolving the problem.


Link to comment
Share on other sites

  • 6 months later...
  • 1 year later...

Hi.  I have a Gen1 (transparent plastic) Flirc, firmware 3.11.0, GUI 3.25.3.  I'm using a URC MX-780 remote control, configured for a Samsung TV device (using NECx2 protocol) as recommended in these forums.  The Flirc is operating an nVidia Shield, and was programmed using the "NVIDIA Shield" template, followed by the "Kodi" template and the "Full Keyboard" template.  I seem to be having both of the problems mentioned in this thread.

For the first attempt, File>Advanced>Inter-Key Delay was set at 3; "Sleep Detection" and "Noise Canceler" unchecked, and "Builtin Profiles" and "Sequence Modifiers" checked.  The problem was that, for example, double-pressing the Home key, which should bring up the App-Switcher, was actually bringing up the App-Selection window, as though the Home key had been long-pressed (or held).  It was difficult to get the App-Switcher window to open; it took a conscious effort to tap-pause-tap.  The same was true of other keys within Kodi.  As another example, moving up or down in a list in Kodi seemed slow; if the button was held, the highligh would move up or down the list rather slowly.  In general, it seemed very sluggish, like after pressing a button there would be a little delay before the response on-screen.  With the Shield's own Bluetooth remote, I can operate buttons as quickly as physically possible, and everything operates correctly--and likewise also with a USB keyboard (Logitech K400) everything operates correctly.

For the second attempt, File>Advanced>Inter-Key Delay was set at 0; "Sleep Detection" and "Builtin Profiles" checked, and "Noise Canceler" and "Sequence Modifiers" unchecked.  This improved the ability to double-press and long-press.  Also, holding down the up or down button in a list, caused the highlight to move up or down in the list much more quickly.  However, now when pressing up or down repeatedly (rather than holding), the highlight moves up or down sporadically; it appears as though a couple taps may be missed, and then suddenly the highlight quickly jumps up or down several items at once.

I'm not sure what to try next, but I believe that it would be very helpful if I had a clear understand of what exactly (technically, under-the-hood) the various options in the Advanced settings window do, particularly the Inter-Key Delay.  But also the others.  For example, the Builtin Profiles option tooltip says "Enable the builtin Harmony Flirc-Kodi profile", but what exactly does that do?  I am using Kodi, but am not using a Harmony, so should I have this option checked or unchecked?  And the Sequence Modifies option tooltip says "Enable this for windows media center", so presumably I should leave it unchecked, but what effect does it have?  Finally, does File>Load Configuration actually load a configuration into the Flirc, or just load it into the GUI?

Sorry for the long post.  Any help appreciated.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...