Jump to content
Flirc Forums

CTRL-F & CTRL-B don't work in Windows Media Center


Recommended Posts

  • 1 month later...

Here's a workaround:

First off, I just received my flirc in the mail today. Its a great product. Much faster then the rosewill WMC remote I was using and allows me to use my comcast universal remote (which IMO is a great remote) http://www.replaceme...te-Control.html

Everything works great except for the skip back/forward as detailed in this thread. So close to perfect yet so far away!

But here's a solution until (if?) there's a fix by Jason:

The short version:

Use autohotkey, map ctrl+f and ctrl+b to a different key, map flirc to that key.

The walkthrough:

-Download and install the autohotkey program at http://www.autohotkey.com

-Use windows explorer (start -> computer) to select a folder in which you'd like to create and store the hotkey scripts (in my case I used the autohotkey folder in the program files directory)

-Now create a script. right click in the windows explorer and select new -> autohotkey script. Rename this one 'back' or whatever you want to call it. Double click on the newly created file and notepad should open up.

-Keep the header text, below that type "(:: Send ^b" note:remove the quotes

-this will make the script execute a control + b when the ( key (or shift + 9) is hit.

-Save the file. Close the file, double click on the file which will execute the autohotkey program and make the hot key active (an 'H' icon will appear in your taskbar).

-Do the same process for the 'skip' file, except this time the text written in the script will be "):: Send ^f" Save and double click to execute.

-Now the "(" and ")" keys can be mapped in flirc to be the back and skip functions on your remote.

-Test in WMC to verify that back and skip now work.

-To make the scripts automatically load during startup, click start button -> all programs -> right click on startup and select "open for all uses" this will open up a windows explorer window. copy the back and skip script files from the folder you placed them in and right click in the startup window and paste shortcut.

-Your Flirc remote is now complete.

  • Like 2
Link to comment
Share on other sites

  • 2 weeks later...

Jason - any updates on this issue?

While Jackstraw's work-around is great, I'm really trying to minimize the amount of customization and 3rd party apps I install on my W7 nettop (other than W7 and XBMC). It would be great if this were built-in to the FLIRC firmware.

Thanks Jason for all your work, and thanks Jackstraw78 for the workaround!

Link to comment
Share on other sites

  • 10 months later...
  • 8 months later...

No more work around needed. This has been addressed in the latest firmware image:



I'd love any and all feedback there. I'm so sorry this took forever, I always had something more pressing on my plate. This was actually a ton of work but wasn't too bad after I completely re-architected all my firmware. 

Please post feedback at the beta forum.

Link to comment
Share on other sites

  • 4 months later...

That beta/rc expired and i've hidden it to avoid downloading the wrong one

Check out out development section for the latest beta/rcs:



Although the current stable firmware is 3.5, so if you open the flirc GUI and check for updates it should upgrade the flirc to firmware 3.5

Link to comment
Share on other sites

I'm still having to use the Autohotkey solution with the latest code. 


Has anyone successfully programmed the Ctrl+F and CTRL+B to work with Windows Media Center without Autohotkey?


Do you have "Sequence Modifiers" enabled in Advanced settings in the Flirc GUI? If not go to File menu and Advanced, tick "Sequence Modifiers" and test those shortcuts without AHK.

Link to comment
Share on other sites



I did as you suggested.  I had some issues with reprogramming the buttons.  I ended up clearing the entire configuration and starting over.  I stopped the AHK scripts and reprogrammed the buttons using the Full Keyboard controller.


I did find where the repeat version of the remote key was also programmed.  In order to clear that, I ran the clear configuration menu option and took an additional step of loading a blank configuration file.


I programmed all the keys. They work sometimes. I may have to press another button before it will work again, Only saw this start in the later releases.


During programming, I saved CTRL+B to the back button on my remote.  But I could program program the buttons to the same button over and over again without the program telling me that it was already programmed.


I am using a RCA universal remote, with WIndows Media Center 7, 

Edited by KenG
Link to comment
Share on other sites

Off and on, during the Super Bowl, I've been working on the buttons.  I ended up just using the My Media Center app from Ceton to give me skip functionality until i work something out.  


I do need to report one thing.  I am not sure the information is cleared when you use the menu option. 


I ran the clear configuration menu option.  When I pressed the skip back button on the remote, it would show the last key combination I programmed (CTRL+B). When I hit it again, it showed me the other combination I programmed prior to the last (the [ key).  


I cleared the config again, then removed and reinserted the Flirc dongle.  That seemed to work.


I'm using a cheap RCA universal remote (RCRPS06GR) that can be bought anywhere for under $15.  I set it to one of the cable provider boxes in order to get a profile that used the skip buttons.   

Link to comment
Share on other sites

One just arrived, a rosewill, doesn't work. = (


I'm not sure why are are getting bad remotes, but this one is one of the most common ones used in HTPCs. It was a toss up between getting the FLIRC and one of these for me.



Link to comment
Share on other sites

I'm not sure why are are getting bad remotes, but this one is one of the most common ones used in HTPCs. It was a toss up between getting the FLIRC and one of these for me.



that's the one I'm using. The USB device does not enumerate. I will try different PC's later this week when I have time.

Link to comment
Share on other sites

Same problem here....using a Harmony 650. Wife is about ready to kill me because she uses skip and back often and i cannot get them to work doing any of the methods mentioned. Is there an eta on this? If not, I likely will have to return.

I understand the problem, and I need to see how windows remotes are working. Please give me until around sunday, I will work on it over the weekend. I'm really sorry for the inconvenience. I've bought 3 windows media center remotes, none of them work. 


I'll make some trips to the electronics store and grab other computers. Once I do that, it shouldn't take me more than the day to figure it out, and implement a fix.

Link to comment
Share on other sites

Well now i am totally screwed up. Program a button and it learns something else. Have tried erasing and starting over and getting same result. Really want this to work but running out of patience


Yeah, if you can't wait until this weekend, I'll accept a return, I'm sorry. I'm just one person and I couldn't begin to describe the amount on my plate.

If you can clear your config, disable 'built in profiles' and record the one key which you think ends up being something different. Post your config after that, and let me take a look.

Link to comment
Share on other sites

Jason, how do I send the config file to you? Here's what I tried tonight. Cleared the config via the menu. Started by erasing the "play" button about 4 times until I received the "this button is already erased" message multiple times. Recorded "ctrl-shift-p" to the play button. Hit the play button and saw that it correctly showed up on the keyboard. Erased the navigation buttons about 4 times. Began recording them one at a time. Tested them and they seemed to work. Hit the play button and now it registers as a down arrow. I am certain I did not mistakenly hit the play button while recording the arrow keys. 

I also noticed, I can use the media key mapping to get the jump forward and back working but it sends two commands as it jumps forward two increments or back two on one key press. I erased and re-programmed these multiple times as well with the same result.

I can wait until Sunday to see what you can figure out but this is a mess right now, I cannot get any kind of functional remote at all at this point. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...