Jump to content
Flirc Forums Windows install fails


Recommended Posts

I'm speculating on the version number based on the icon link below.

Flirc's instructions says to double-click on "SkipApp.msix", but their web site downloads a "SkipApp Installer.exe".

There is no digital signature on the .exe; this doesn't take a new installer, guys.  Please spend of a couple hundred bucks per year for a Windows digital signature and sign all the .exe that you provide.

Users (including myself) do not feel good about running a program that Windows warns is dangerous.  Said users get even more concerned to see the installer spawn some sort of PowerShell script for a fraction of a second to do heaven only knows what.

And when the installer finishes, there is a desktop and start menu icon that points to:

"C:\Program Files\WindowsApps\1ee3f564-2cd0-4ef3-af35-da985b1d7f00_0.9.0.5182_x64__vg5akken3mtem\SkipApp.exe"

but there is no such WindowsApp subdirectory, nor a SkipApp.exe anywhere on the computer's file system.  Any attempts to run the software just result in Windows saying the executable can't be found.

OS is Windows 10 Pro 21H2

Link to comment
Share on other sites

I am having the same problem with the Skipapp on Windows 10 Pro. The icon shows on the desktop but the app doesn’t seem to be installed. The app does not show on the start menus and there is not a folder for it in the program files folder. 

The icon on the desktop attempts to open this:


"C:\Program Files\WindowsApps\1ee3f564-2cd0-4ef3-af35-da985b1d7f00_0.9.0.5182_x64__vg5akken3mtem\SkipApp.exe"

I don’t have a file in my Program Files folder called Windows Apps. 

I have tried downloading and installing the app several times with a reboot each time but the result is always the same. 

Link to comment
Share on other sites

I'm seeing the same issue, honestly the only thing that the installer seems to do is create a bunch of folders at
C:\Users\[user]\AppData\Local\Packages\1ee3f564-2cd0-4ef3-af35-da985b1d7f00_vg5akken3mtem, including:

  • AC
  • AppData
  • LocalCache
  • LocalState
  • RoamingState
  • Settings
  • SystemAppData
  • TempState

And the only folder that actually contains anything is settings, which includes:

  • roaming.lock
  • settings.dat

There is also the .ico file in AppData/Roaming/SkipApp, but that's it.

I've got to piggy back on @pinaz, seeing an unsigned application is bone-chilling, especially when a random PowerShell terminal pops up. I was originally trying to install this on Linux using Bottles, but after failing to after about an hour of trying different dependencies and methods, I booted into Windows only to figure out that the application doesn't even work on its intended platform. I'm really hoping to see this fixed; it's not a good start to a launch of a new product. I'd have expected something as broken as this to be caught by a QA team.

Edited by worksonmybox
personal info
Link to comment
Share on other sites

I downloaded V0.9.1 Beta installer and ran it as administrator.  It put the executable in C:\Program Files\WindowsApps\1ee3f564-2cd0-4ef3-af35-da985b1d7f00_0.9.1.5229_x64__vg5akken3mtem

It also created a desktop shortcut

Problem: Windows is denying permission to run the program from the WindowsApps folder system even as administrator

I cannot start the program


Link to comment
Share on other sites

I successfully changed the owner of the WindowsApp folder to my windows user name (with execute permission and now the shortcut stars to launch the program, however, I now get the following Error: "SkpApp.exe - System Error: The code execution cannot proceed because SharedLibrary.dll was not found.  Reinstalling the program may fix this problem.

Link to comment
Share on other sites

For anyone having the folder permission issue, these are the instructions I followed to resolve it

"Right click on the folder, select "Properties", click on the Security tab, click on the "Advanced" button. Next to Owner click "Change", then click "Advanced" and proceed to select "Find Now". Expand the "Name" column on the bottom section of your current window so you can view all the available selections. Scroll down until you see your username, select it and click OK. Click OK on the "Select user or group" window and finally click "Apply" on the window titled "Advanced Security Settings for [folder]" Close out of the dialogue box and properties windows.

You now have full access to the folder."

Link to comment
Share on other sites

  • Nathan locked this topic
This topic is now closed to further replies.
  • Create New...