Jump to content
Flirc Forums

Works connected to desktop monitor, doesn't work when connected to TV


Strategus
 Share

Recommended Posts

Flirc USB adapter works when computer is connected to old Samsung monitor via HDMI, but stops working when PC is connected to oldish (dumb) JVC TV via HDMI.

I got everything setup the way I wanted using a monitor on my desk connected to a Linux PC running Kodi. However, when I connected the same setup to my JVC TV set, the remote stopped responding.

I need some suggestions as to how to proceed debugging this issue.

Thanks.

 

Link to comment
Share on other sites

The attached keyboard works in both configurations. The Flirc shows up in both configs, but doesn't work connected to the TV. Bizarre!

 

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 0e8d:0608 MediaTek Inc. Wireless_Device
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 20a0:0006 Clay Logic flirc
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 

I'm using a wireless Logitech keyboard, but using a wired keyboard doesn't change things.

 

 

Link to comment
Share on other sites

Running Flirc connected to the desktop monitor does what I'd expect and key presses register:

 

Tue Dec 13 2022 21:04:55
Flirc GUI Version v3.25.3
Operating System: Linux
*** Device Disconnected ***
*** Device Connected ***
Firmware Version: v4.9.3
SKU: Flirc 2.0 [dori]
Git Hash: 0xcb185bde
<1>malloc_addblock(49): Heap Block: 0x20001A7C - 0x20003BFF (8k)
:e:27665
....remote key presses show....

 

But when attached to the TV:

 

ue Dec 13 2022 21:11:13
Flirc GUI Version v3.25.3
Operating System: Linux
*** Device Disconnected ***
*** Device Connected ***
Firmware Version: v4.9.3
SKU: Flirc 2.0 [dori]
Git Hash: 0xcb185bde
<1>malloc_addblock(49): Heap Block: 0x20001A7C - 0x20003BFF (8k)
<3>ir_finished(63): too many edges

Key presses don't show up (too many edges?)

 

my_flirc_log-jvc-tv.txt my_flirc_log-desktop-monitor.txt

Link to comment
Share on other sites

16 hours ago, Strategus said:

The TV has a setting named "CEC". If that is set to "disable", we get the "too many edges" message. If it's set to "enable", that message goes away. Unfortunately, the remote doesn't work with either setting.

 

Yep, that's weird. We've now gone past my knowledge base. I'll ask Jason to take a look, but it may be a bit. With the Skip 1s getting ready to ship, it's been all hands on deck.

Link to comment
Share on other sites

I appreciate your time and help. I'm anxious to get my hands on the Skip 1 myself. My Harmony is getting a bit dated.

 

FYI. Just for grins I moved the Flirc over to a Pi 4 and tried the same experiment with the same result. I also tried different HDMI cables.

 

I'd say just back-burner this for a while, maybe forever. If I have some epiphany I'll post back, but you needn't worry about it.

 

Link to comment
Share on other sites

12 hours ago, Strategus said:

I appreciate your time and help. I'm anxious to get my hands on the Skip 1 myself. My Harmony is getting a bit dated.

 

FYI. Just for grins I moved the Flirc over to a Pi 4 and tried the same experiment with the same result. I also tried different HDMI cables.

 

I'd say just back-burner this for a while, maybe forever. If I have some epiphany I'll post back, but you needn't worry about it.

 

Oh interesting. So regardless of the host computer, the TV is interfering with the Flirc? Reading some past replies with this issue, it sounds like what might be going on is some kind of IR bleed. For some reason light might be hitting your Flirc that the Flirc is interpreting as commands, so it can't see whatever remote you're using. Might try blocking your TV remote or, as a test, blocking off the Flirc with a paper towel or toilet paper tube or something while it's plugged, so the only thing it can see is the remote you're using to control it on the other end of the tube.

Link to comment
Share on other sites

I turned on the TV and took the TV remote out of the room completely, and blocked off the sides of the Flirc with a paper towel tube. After powering on the PC, the remote (a Harmony 880) worked for a few seconds (5 or 10?) and then quit. I don't know. Poltergeists?

With the clarity of hindsight, I brought the TV remote to my desk. The Flirc works just fine with the TV remote sitting next to the PC. Maybe I'll try painter's tape over the IR sensor in the TV. I dunno. Do IR receivers ever transmit "junk"?

 

Edited by Strategus
Additional insights.
Link to comment
Share on other sites

I believe I've eliminated IR weirdness from the equation. I took the PC, my desktop monitor, and the keyboard/mouse into the room with the TV. First I powered on the PC and monitor (exactly as when on my desktop), and the remote control/Flirc worked perfectly. Next I powered on the TV and played with the TV remote. The PC/Flirc/remote continued to worked fine. This implies to me that the issue has something to do with the HDMI connection between the TV and the PC.

Just to be clear, there was not a connection of any kind between the PC and the TV in this test. I wanted to see if there was IR coming from the TV perhaps.

 

Link to comment
Share on other sites

First hint was 'old' tv. 

Old TV's have a lot of terrible light noise, namely, they emit IR. And then I scrolled down and saw, 'too many edges'. So it's seeing a bunch of junk from your TV. 

  • Make sure flirc is not in the line of site of the TV. It's good underneath it, or behind it.
  • Make sure you record and setup flirc without the TV on. Go in another room, format flirc. Then set it up again making sure you don't hit record and it ever says 'recorded successfully' without you actually hitting a key. Means you just recorded noise. You'll need to hit delete, and then wait for it to be 'seen' again. Or hit format and start again.
  • Go into advanced and disable all built in tables you aren't using

Let me know how that goes.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...