Jump to content
Flirc Forums

Flirc Continues Endless Keypresses on Harmony 650


Recommended Posts

  • 4 weeks later...
  • Replies 57
  • Created
  • Last Reply

Top Posters In This Topic

mine's used with a harmony ultimate. flirc 1.3.6 with firmare 3.6.

i am not sure if the problem was in before, but lately, i've had scripts that did automatic configuration changes to the flirc. it didn't seem to like that too much, and at some point the driver/firmware got corrupted. i reinstalled the driver and firmware and mostly things seem to work now.

one thing that still seem screwed up is the modifier keys. ctrl, alt, and shift mostly seem to be getting stuck and keep being sent although i can see on the harmony hub that nothing is being sent IR-wise.

so if i have a combination of shift-alt-F7, then mostly, after i use it, the shift-alt are still being pressed, and if i hit F9, it'll actually do shift-alt-F9. this is pretty bad, as if i have only alt as a modifier, then things really go crazy since alt does shortcuts with many things.

i had to remove all modifiers from everything in order to get things not to go haywire.

Link to comment
Share on other sites

  • 3 months later...

I have 3 Flircs that I have been using for well over a year with Harmony 650s and MythTV (MythBuntu 14.04.3). I recently went to modify a button on one unit and was instructed to upgrade the firmware (which of course wiped out all my programming). After the upgrade I restored my configuration file and nothing worked. I had to manually all of the buttons on that unit. Ever since the "upgrade" it has been sending unusual commands to MythTV. Most of the problem keys are compound (Ctrl+Alt+XX) keystrokes but a couple are simple (like a D).

I found mention of a firmware 3.7 and tried to follow that link but it would not redirect. I also found that the latest version (from https://www.flirc.tv/downloads) is supposed to be 1.4.0 but when I try to upgrade to it (apt-get-update and apt-get install flirc) I get the message that I already have the latest firmware. my sources.list does have the correct repo for flirc in it.

I've concluded that 3.6 is a waste. Is there something newer that fixes the problem with the double/random/endless keys being sent by Flirc? If so, how do I find it? If not, how do I revert to a version that works?


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...