Jump to content
Flirc Forums

Power up macro's


Recommended Posts

I received my remote yesterday and I have been fidling around a bit, but I don't seem able to make macro's work. It will only start the first configured device and do no more after pressing the power button.

For example:

Activity A is "watch TV". First I added the setup box and secondly the TV. This will only start the setup box, no matter the order of the macro. The macro also should change the input selection on the TV, this isn't working either.

Activity B is "streaming". This has only the TV and it will start the TV, but not switch to the home screen as added into the macro.

Activity C is "Watch movie". This has the TV as primary device, and the blu-ray player as the second device. This will start the TV and not the blu-ray. If I remove the TV all together from the power up button macro only then it will start the blu-ray player. Changing the TV input isn't working on this macro either.

If I add all power up buttons or the HDMI selections on a separate button all functions are working fine. So something with the macro setup is the culprit, but I have no clue what it could be. I also tried it with the .10 beta firmware, but this didn't change anything for me.


Anybody got any clue how to make the macro's work?

Link to comment
Share on other sites

drBunhead, I believe it is the same issue I have been experiencing, too.  Did you happen to try the Test Actions option in the pancake menu on the right side of the Actions modal where you add your Power Up actions?  If the remote is connected that allows you to test running your Power Up and that seems to work for me but when I unplug and push the button it doesn't.

Link to comment
Share on other sites

1 hour ago, John Doe said:

Switching input and turning on devices by activity button is not working! The one thing this thing should do, it can not do.

Hi John, while I appreciate your enthusiasm in posting, please don't push your requests onto unrelated threads. This thread is about a bug when hitting the power button and the second action in the macro doesn't happen. It's not related to your feature request.

@drBunhead yep, it's a known bug with the current beta. We're working on tracking down the problem and posting a fix. In the meantime some users have said changing repeat to 3 fixes the issue.

  • Thanks 1
Link to comment
Share on other sites

On 2/24/2023 at 2:41 PM, P.Verbrugge said:

Can this be a firmware issue?

When I received my remote and started playing with it, it initially seemed to work fine. When I upgraded my remote to version x.10, it broke.

Original firmware didn't work either, that's why I tried x.10.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...