Jump to content
Flirc Forums
Adri

Flirc not working after upgrade to 3.25

Recommended Posts

Well that didn't work. Installed linux on a laptop and then installed flirc software. Still can't get past 3.11 on software. Does anyone have any suggestions to try on a gen 1 flirc? My problem is that I can not get the simplest of controls (minimalist) to work on the flirc. Some keys will function but others don't. Up arrow goes up, down arrow goes up, right arrow goes right, left arrow does nothing, return makes a noise.

I have tried to manually install 3.12 using the method outlined in the forum and it does not seem to take. I have updated the drivers and it does not seem to make a difference. I am using 3.25.2 on the software. I've tried both windows and linux on this gen 1 flirc.

Thanks in advance for any help you can give me. I have attached a log file of the upgrade. Hope that will help.

flirc_log.txt

Edited by Daddis

Share this post


Link to post
Share on other sites

Hi @jason

are there any news?

With 4.9.3 Pause Button is not working - Rest is OK. (4.7.0 works fine)

Are there any Firmware version between 4.7.0 and 4.9.3 (Dori) which i can test?

Edited by JohnWayne

Share this post


Link to post
Share on other sites
On 12/20/2019 at 9:28 PM, jason said:

Okay, I think I got it. Everyone was using windows, and there was something that needed to be fixed in my report descriptor and it looks like other OS's were more lenient. Sorry, please try the attached.  File->advanced to get your sku, and then do file->upgrade ,and upload one of the attached.

gen 1 devices can use the flirc-gen1v3.12.bin file

 

nemo.release-4.9.1.bin 60.63 kB · 4 downloads dori.release-4.9.1.bin 60.5 kB · 10 downloads

flirc-gen1-v3.12.bin 12 kB · 16 downloads

EDIT: found the other post saying 3.11 is latest now, FLIRC wasn't successful at working when I was remote logged into the machine, but recording the activity I wanted worked directly on the machine itself.

Edited by ncer

Share this post


Link to post
Share on other sites
On 12/21/2019 at 3:15 AM, jason said:

Oh I'm so sorry, I modified the content and forgot to update the CRC. Try the attached.

Sunrise_Flirc_updated.fcfg 348 B · 5 downloads

Hi Jason,

it works mostly now, but there are still some issues controlling the Sunrise box with Flirc after firmware upgrade.

  • DVR button is not working anymore
  • Back button is not working anymore (not sure if it was before though)
  • Forward/rewind are behaving differently than before
  • all the virtual buttons programmed on the touch screen of the Harmony Ultimate One do not work anymore (they did work after firmware upgrade before loading quoted file, but all physical buttons did not work anymore)

I attached you config file that has been working flawlessly with previous firmwares for the last few years with Gen2 version of the IR receiver.

Can you probably help with this?

Am on a Windows 10 x64 machine using newest versions of Flirc GUI and firmware.

 

Sunrise_Flirc.fcfg

Share this post


Link to post
Share on other sites

If you upgraded to the latest firmware, you'll have re-pair many of these keys. I changed the way the report ID's work in USB to be more compatible with other devices, and the way the old config sent them up doesn't work with newer firmware. So what I'd recommend is loading this file. Hit delete in the GUI, and re-record the button / function again. Let me know if that helps.

There is a ton of work I want to do with Flirc that's in the pipeline. I am at a standstill with my employees at home, the virus disruption in life and my supply chain (since january), and all the stress that comes with this. I'm really sorry. Still alive, working just as hard.

Let me know how this goes.

Share this post


Link to post
Share on other sites
5 hours ago, jason said:

If you upgraded to the latest firmware, you'll have re-pair many of these keys. I changed the way the report ID's work in USB to be more compatible with other devices, and the way the old config sent them up doesn't work with newer firmware. So what I'd recommend is loading this file. Hit delete in the GUI, and re-record the button / function again. Let me know if that helps.

Hi Jason,

unfortunately there is no way to re-record the buttons since the original remote supports bluetooth only. 
The codes were taken from here, the thread starter found them by trial and error method I guess.

Is there an easy and supported way to downgrade to previous firmware probably in the mean time?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...