Jump to content
Flirc Forums

jason

Administrators
  • Posts

    2,695
  • Joined

  • Last visited

  • Days Won

    116

Everything posted by jason

  1. Open up my app on your PC, go to File->Device Log. Enable IR debugging. And press and hold the button in question. Post the log here.
  2. It should work, unless you are using a harmony. What remote are you using?
  3. Oh shit, I know what's going on. Sorry. You have two devices. For convenience, each device is setup to work with the harmony profiles out of the box, but can't know what it's plugged into. So all are enabled. Download my software, insert Flirc1. Go to file->Advanced. Disable All but Shield. Plug back in shield. insert Flirc2. Go to file->Advanced. Disable all but firetv. Plug back in firetv. So sorry about that.
  4. They should not be using the same commands, they are different. You aren’t pairing them with my software are you? Those profiles are pre-paired.
  5. It must be the backlight in your TV, it's emitting IR. Learn the signals with the TV off, and then it should ignore those spurious signals. Give it a shot, let me know.
  6. can you post your saved configuration?
  7. try in another room. Probably the lights. Let me know how that goes.
  8. @qwerky Overloaded with work, send me an email, I'll send you a new gen flirc. I don't want to look into the first generation at the moment.
  9. Are you by a window, or by a TV or under lights that may be fluorescent? If so, can you try recording in a different area?
  10. It's written, I haven't had time to finalize it. This virus really messed up schedule. Our new case is behind schedule, my supply chain is constrained, and everyone is staying home so I spend a majority of my time fulfilling orders. I should be done with this project I'm working on next week and will get back to firmware.
  11. If you upgraded to the latest firmware, you'll have re-pair many of these keys. I changed the way the report ID's work in USB to be more compatible with other devices, and the way the old config sent them up doesn't work with newer firmware. So what I'd recommend is loading this file. Hit delete in the GUI, and re-record the button / function again. Let me know if that helps. There is a ton of work I want to do with Flirc that's in the pipeline. I am at a standstill with my employees at home, the virus disruption in life and my supply chain (since january), and all the stress that comes with this. I'm really sorry. Still alive, working just as hard. Let me know how this goes.
  12. No. But you can imagine how hard it's been with the virus. Everyone is at home. My supply chain is constrained, and I have to do everything myself.
  13. Open a terminal, try this: DEBUG=true /Applications/Flirc.app/Contents/MacOS/Flirc
  14. What? Sorry, what are you talking about? What's a MS media center keyboard? Which remote are you using? Can you post a link to the remote?
  15. I think this is because your OS is 32 bit, and it's really hard for me to make a 32 bit application. Do you have another system? You just need the app for the pairing process.
  16. Excellent, you got it. Thanks for posting the follow-up, and let me know if I can do anything else to help or improve the app.
  17. What remote control are you using? There are no problems with the log. It’s working as it should. Does the remote respond?
  18. Sorry for the delay. The flirc.ini needs to be in the same directrory as the executable. Here is a quick trick you can do: DEBUG=true flirc_util settings
  19. I believe I use the media center 'play/pause' keys, which are global. You need to determine the common keys for pause. Here are the shortcuts according to Netflix: Space - Toggle Play/Pause Enter - Toggle Play/Pause F - Full-screen Esc - Exit full-screen Left arrow - Rewind 10 seconds Right arrow - Fast Forward 10 seconds Up arrow - Volume Up Down arrow - Volume Down M - Mute toggle So is it enter or kodi that is doing the pause? You just need to record over the current play/pause keys to either space or enter. I'm assuming it's space. You can do that in the keyboard controller of the GUI.
  20. If you go to file->format configuration, that restores it to the default state. If it’s still re-acting to button presses, go to file->advanced, and disable all built in profiles.
  21. do it directly on the machine, if it's still in open space, it should be fine. Mine is inbetween the wall and the TV, doesn't skip a beat. Also, don't record too close. It's super sensitive.
  22. I have only seen this in one place before, which is on Cortex ARM-A7's, there seems to be a bug in the upstream kernel. The only way I was able to circumvent this was by increasing my USB-Poll time. I need to have time to continue to debug it, but it's a fairly complicated issue. I wouldn't rule out that there is something wrong with the hardware just yet. Can you try different ports on the computer? Is this a hub? Directly on the PC? USB 2.0, or 3.0 Hub? The bug is just with the pairing software, should not prevent flirc from working correctly. The issue with the double record is most likely the protocol you have setup on the harmony. Some alternate patterns on every press to help detect when the user let go of the button, or someone walked in front of the remote. On the harmony software, add manufacturer Flirc, device: Kodi.
  23. Yeah. I’ll post this next week
×
×
  • Create New...