Jump to content
Flirc Forums

Booting straight to XBMC does not load driver


Recommended Posts

It appears as if the driver isn't loaded If i boot straight to XBMC (in Win 7), using the following guide (using the MMC in step 2 -- no eventghost):


Nothing happens when I press any button on my remote. Everything functions perfectly if I boot into explorer then launch xbmc. Can anything be done to fix that?

Link to comment
Share on other sites


Problem is in fact that you have removed windows shell - explorer an with it explore's auto play function.

This function searches for removable drives and devises.

In other words - your pc has no ability to discover your usb dongle.

If you can access cmd after boot you can enter

mmc devmgmt.msc

That will open your device manager, try searching for hardware changes and see what happens.

If that works well then it is 100% explorer problem.

Perhaps better solution would be to make eventghost shell, it has system plugins, maybe there is a way to force search of hardware with eventghost

Edited by burke
Link to comment
Share on other sites

  • 1 year later...

hey guys,

when at least @BaggaDonuts  is not giving any feedback, I can do.


Short Version:

* If you don't have Windows Explorer enabled, enable it now,

* load / start flirc app once manually and load config,

* reboot

* since that moment everything will work as expected.

* done ;)


Took the infos and just double checked.

Problem for me was: Using XBMC Launcher (Launching XBMC directly without explorer, I faced the same issue).

After restart I had to manually open Flirc App, (it showed some message about initializing bootloader, sometimes it already worked, sometimes loading config too).


After enabling Windows Explorer and afterwards launch XBMC, it automatically also loaded Flirc Driver and everything works as expected.

Can definitly live with this solution (but it's not as cool as seeing XBMC directly boot without seeing Windows Taskbar / StartMenu ;))))))


Cheers && thanks for the hint,



finally: fuck*d ;P

didn't work for me, constantly. i'm not sure what's wrong, but it looks like some initialization sometimes goes wrong.

for now i test: power settings -> disbale suspend for usb on sleep.

probably then it will work ;)

will keep you updated.

Edited by m2k
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...