Jump to content
Flirc Forums

Flirc doesn't pass on keypresses


Recommended Posts

First want to tell excuse me if I'm in the wrong section but couldn't find a support section.
Edit (I meant to post this in the general questions section, darn you browser tabs :P).

For a few years I've really enjoyed using my Flirc SE and it's like the perfect companion to my htpc! Just love it.
Unfortunately since yesterday since I did some maintenance to my htpc it stopped working, in an odd way.

So what's so odd about it? well it still records remote ir signals when I point at it, and it still gets recognised.
If a key on the remote was already learned it gives the proper message too so nothing appears to bewaring at first glance.
Except in Kodi or in a text editor test you don't see keypresses anymore! (have it passing on letters/numbers)
Since it's a SE version I thought maybe the USB cable had gone bad and replaced it, but no luck.
Upgraded the firmware to the latest 3.9.0 but no luck either there.

Is there anything I could do or test besides buying a new one? It's out of warranty for sure.

BTW if you were to do a V2 for my streacom case I'd totally buy one!

Edited by Boldo
Link to comment
Share on other sites

The mystery deepens;

I can get it to work by plugging and unplugging the husband header in many times...like every 20th time it will work.
Now the mystery; it will keep working until I restart the htpc or shut it down after which I need to do the same routine to get it working.

Any idea what this weird behaviour is?

Edited by Boldo
Link to comment
Share on other sites

Well I've tried a few remotes which were laying around in the house with no result; same behaviour.
The gui still sees the Flirc connected (device log) and it behaves like this;

When Kodi doesn't receive keypresses;
- On button learning it will say the button has been already mapped
- When pressing buttons the keys won't lid up

When Kodi receives the keypresses;
- On button learning it will say that button has been already mapped
- When pressing buttons the keys will lid up like it's supposed to be

I'm really not sure what this could be; faulty firmware would cause the receiver not to work at all I'd imagine or more constant behaviour, both of which is not the case.
And if the USB connection were bad it wouldn't be connected at all? It makes no sense whatsoever.

I'm not familiar with the zadig tool, will look it up and report back.

Link to comment
Share on other sites

A few developments but no solution yet:

Followed this support article; https://support.flirc.tv/hc/en-us/articles/200712548-Using-the-ZADIG-Utility
I can upgrade to libusbK with the latest version but no difference.

Finally my replacement Flirc came in, a new revision with black PCB and overly unnecessary blue led on the back, and exactly the same behaviour!
So we can eliminate it comes from the Flirc itself, it should be driver related.
Also ever since connecting the new Flirc, I get this error in the Device log;
"Error, unsupported device. Must have Flirc Gen2 enabled device and fw >= 4.1.0"
Can't seem to get rid of this 'error' now.

With the black one it's the same story; first time connecting it worked, next reboot it still worked, but after that it's unplugging and plugging back in till it works which can take up to 15 min to do. 

Thinking about the maintenance I did after which this happened; it was only using some compressed air to clean the htpc (which I do with all my pc's every year), upgrade to windows 10 version 1709 and since I got problems upgraded to the latest Flirc + FW. Beginning to suspect it's the windows update causing all of this as this setup had been working perfectly since november 2015.

Link to comment
Share on other sites

Well a small update; I can reproduce what you did via teamviewer perfectly and when rebooting it works flawlessly.
But on a cold boot (at least 1 min off) it refuses to work.

I really have no clue what this is anymore and it's hard to test for you via teamviewer...
Any ideas to where to look next?

Link to comment
Share on other sites

  • 2 months later...

Indeed the streacom board.
Maybe you like to have the specs of the current setup, it's somewhat older and that might have something to do with it;

Intel DH77EB motherboard

Planned to upgrade this pc to a more modern setup but still waiting for the new B/H boards by Intel.
It's the only reason why I haven't done a total reinstall yet.
Have ran a few linux live usb sticks and that confirms the problem lays with the os, maybe drivers, and not the actual hardware.

Link to comment
Share on other sites

You've seen it yourself over teamviewer, but I'll recap;

Yes the gui still detects it, both the older and newer board as I bought a new one as I thought it was faulty.
To make it work again I have to reconnect it about 20-30 times or remove it from the device manager and reinstall it etc etc.
If I do a hot restart everything keeps working with no issues, but ofc you don't leave it on 24/7.
From a cold boot you got this exact problem, ever since the windows 1709 update.
The only thing I've tried since is renew the USB drivers with the latest inf pack from Intel to no avail.

Link to comment
Share on other sites

Well Jason had a look and I missed his last msg in teamviewer.
But for anyone researching this, it seems to be a common issue with USB hardware with the 1709 patch, much as I suspected.
Unfortunatly not a lot can be done from Jasons end.
Believe I just read in time he wanted to make a post about it in case anyone has the same issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...