Jump to content
Flirc Forums

New user trying to get Kodi and Harmony 650 working.(Windows)


Recommended Posts

Need some newbie help, please. I purchased a Logitech Harmony 650 last week. So far, it is working great with my TV, receiver and Yamaha sound bar. I got my Flirc IR usb dongle today in the mail. I connected it to my htpc and ran the setup and installed the drivers. I upgraded the firmware when prompted. I added it as a device to my 650 ( Flirc/Kodi) and all seemed fine. I then mapped keys in the Flirc GUI and that process seemed to go smoothly as well. All keys reported they mapped fine as I was doing it. But still, if I launch Kodi, not a single key on the 650 is working. 

Do I need to do anything else? Must the Flirc software be open for this to work? This is Kodi 17 (Krypton, btw) I have read several setup guides and I can't really see where I am going wrong. 


I also saw where I should check to see if built-in profiles are enabled, and they are. I guess I didn't need to map all those keys. Still not working, however.


Thank you!


Edit: I just noticed in the gui log the below error message:




Edited by dmaker
Link to comment
Share on other sites

What kind of flirc do you have?  A metal or plastic version?

You did everything right, however, you actually don't need to pair anything. Once you add the flirc - kodi profile to your harmony, flirc should work with it without any additional pairing. It's built in.

But it should still work the way you did it as well. Can you tell me what's not working?

Link to comment
Share on other sites

Hi, thanks for the reply.

I purchased this one: 

FLIRC FL-09028 USB Universal Remote Control Receiver for Media Centers Components

Nothing seems to work. I tried navigation keys, media keys (such as play, etc) and the back button. Nothing happened at all. But, as I mentioned, the key mapping went fine. 

This is Windows Server 2008 R2, btw. And, also, I do have kodi configured to accept input from other sources, for example, the Android remote control app works fine on my phone. I understand that is wifi, not IR, but just trying to give as much information as possible.








Edited by dmaker
Link to comment
Share on other sites

Any more suggestions? I'm not sure what else I can do. I really would rather not go through the hassle of returning it to Amazon. I don't think it's faulty, as I can map keys fine. The software recognizes when I press a button on the remote, but Kodi does not seem to.



Link to comment
Share on other sites

It's working now. Very odd, but Logitech online support suggested adding a new device using Flirc/Windows Media Center. I did that, then selected that as the active device. It still did not work. I then tried the original Flirc/Kodi that I had not removed and it now works. I deleted that Flirc/WMC device from myharmony and the Flirc/Kodi one is still working. 


Seems very strange, but that is what worked for some reason. 



Is there a button map diagram or something for Kodi with Flirc? I can figure out the basic ones, but would be nice if there was a contextual menu, and a few others maybe already baked in. 


The pause button does not seem to actually pause. Am I missing something?  Nevermind, seems to be pausing now.  Well, sort of...definitely flaky.






Edited by dmaker
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...