Jump to content
Flirc Forums

Windows 10 - Flirc Disconnected


Recommended Posts

I am having the same problem.  Just received my (metal V2.0) Flirc yesterday.  I downloaded and installed the GUI today (3.9.8).  After the install I plugged in the Flirc to my Windows 10 64bit (1709 build 16299.192) and after in installed the hardware the GUI still says disconnected.  I tried uninstalling the Flirc device from Windows and uninstalling the software and reinstalled as administrator and reinstalled the device but still no go.


Link to comment
Share on other sites

5 hours ago, Slaughterhouse said:


Was there a resolution to this thread? I am experiencing this issue. All steps above to troubleshoot have been taken.

GUI = v3.9.8

Flirc = v2 (metal)

This is happening after I recently moved. The Flirc device has worked on this box previously. This time, when I plugged in the device, I was prompted to do a firmware upgrade, which I did. Since then, the device has been "Disconnected" in the GUI. The GUI installed goes through installing drivers, and Windows appears to finish installing the device when I plug it in.

I have uninstalled and reinstalled the device and the GUI. Rebooted, ran everything as administrator, etc. Any help is appreciated!



Can you post a log like the user did. Not to worry. I’ll get it working. 

Link to comment
Share on other sites

This was different than what this posting originally was. Llooks like this was a bug. I'm pushing an update. Should be posted in about 30 minutes. Infuriated about the bug. 

Im using hidapi, and am actually jumping on to be a maintainer. For some reason, the interface number for the USB device is showing up as -1, should be 0. Want to pull my hair out.

Link to comment
Share on other sites

  • 2 months later...
  • 2 months later...

The app used to work, now suddenly it does not.

The (old plastic) Flirc still works and responds to my remote control. But the app insists it's disconnected.

Have tried what I could from the usual suggestions here.

This may be related to my recent Windows 10 Update to 1803.



Edited by Glenn Reimche
Additional info
Link to comment
Share on other sites

  • 4 months later...
  • 3 weeks later...


I have Flirc SE and my GUI also says Disconnected.

I'm using Windows 10 Professional after I've upgraded from Windows 7 Professional where all was fine. Flirc is still working but the GUI is not.

I've downloaded the latest application from https://flirc.tv/downloads and ran as Administrator.

I've also tried Zadig to set the driver to libsublk as I find written on the support pages, all to no avail.

I've reinstalled the drivers at least three times.

On the flirc log I can see some errors here, namely about a bootloader which i don't see defined anywhere:

[D] gui/Flirc/src/main.cpp main(218): --------START OF MAIN---------
[D] gui/Flirc/src/main.cpp main(221): flirc_util version v3.20.4 [3.20.4]
[D] gui/Flirc/src/main.cpp main(222): Operating System: Windows
[D] lib/libflirc/flirc_driver.c fl_get_sku(1443): pointer to handle is invalidn[V] gui/Flirc/src/mainwindow.cpp stopCurrentOperation(1361): stopping current operation
[V] gui/Flirc/src/mainwindow.cpp stopCurrentOperation(1375): got to the end
[D] gui/Flirc/src/mainwindow.cpp device_disconnected(268): Device disconnected
[D] gui/Flirc/src/advanced_window.cpp update_fields(296): disabling all the menus
[E] gui/Flirc/src/device_log.cpp update_fields(139): updating fields, present: 0
gui/Flirc/src/mainwindow.cpp display_fw_version(307): no device connected
[V] gui/Flirc/src/mainwindow.cpp checkHardwareStatus(335): checking status
[D] lib/libflirc/common/flirc_transport.c fl_open_hid(124): trying to open bootloader device
[V] lib/libtransport/hid.c hid_dev_open(330): Device 20A0:5 not found
[V] lib/libtransport/transport.c dev_open(88): no device found
[V] lib/libflirc/common/flirc_transport.c _fl_open_libhid_btldr(56): no hid device found
[D] lib/libflirc/common/flirc_transport.c fl_open_hid(130): trying to open main device
[D] lib/libflirc/common/flirc_transport.c _fl_open_libhid_app(92): trying to open 0x20A0, 0x0006
[V] lib/libtransport/hid.c hid_dev_open(330): Device 20A0:6 not found
[V] lib/libtransport/transport.c dev_open(88): no device found
[V] lib/libflirc/common/flirc_transport.c _fl_open_libhid_app(94): no hid device found
[V] lib/libflirc/common/flirc_transport.c fl_open_hid(136): no device found
[D] lib/libflirc/common/flirc_libusb.c fl_open_libusb(147): trying to open bootloader device
[V] lib/libtransport/transport.c dev_open(80): no device found
[V] lib/libflirc/common/flirc_libusb.c _fl_open_libusb_btldr(76): Bootloader v2 not found: PID: 0x0002
[V] lib/libtransport/transport.c dev_open(80): no device found

Please help me.

flirc symptoms.zip

Edited by cochinada
attaching logs and print screens
Link to comment
Share on other sites

  • 1 month later...


Hello forum,

After we received no support.

I found a short-term solution to our problem.
It is hard, but it helps until a software update solves the problem.

You create a previous WIN version with a USB stick, e.g. 8.1
with WinToUSB. Start the newly created system via the BIOS.

There you can quickly install the Flirc software and program the FLIRC-SE.

The program is maintained !!!

After changing the boot menu to your Win 10 system in the BIOS again.

Voila, the new programming is still there.


Edited by lordduckstein
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...