Jump to content
Flirc Forums

Press and hold doesn't work with v3.5


Recommended Posts



after upgrading to firmware 3.5, I cannot get long key presses to work.  I tried 3 different remotes.  All of them used to work with flirc just fine.



Format flirc, learn a key, say 'x'.

Open a text editor, press and hold the button on the remote.


Expected behavior:

One 'x' should appear immediately in the text editor.

Then many 'x' should appear due to key repeat as long as I hold the button on the remote.


Observed behavior:

Most of the times, a single 'x' appears immediately and then nothing else happens (all while holding the button on the remote).

Sometimes, 10-20 'x' appear and then the repeating stops.

Very rarely the key gets stuck and 'x' appear until I unplug flirc or hit a key on the usb keyboard.



I've tried all values of inter-key delay with no observable change.


Is there anything I can do?

Edited by foobar
Link to comment
Share on other sites

The remotes are

1. From a Yamaha RX-V373 receiver.

2. From an Epson TW 3200 projector.

3. Universal Remote URC 7960. I've tried the device codes of various TV and SAT receivers.


I checked with my cell phone camera to verify that the IR LED is lit all the time when holding a key.

Link to comment
Share on other sites

I see no change when I set the interkey delay to 5 or 6.


Flirc also sometimes seems to ignore remote button presses.  It feels less sensitive than before.


Actually, I upgraded to firmware 3.5 in the hope that it would fix the troubles my flirc developed in the last 1-2 days.  First it stopped responding completely, then after changing the USB port and relearning the keys, I had the problem of keys getting stuck almost every time on a long press.  I don't remember the exact firmware version, but it was 2.x (with flirc gui 1.2.6).


edit: I just wanted to add that I have been using flirc almost every day since July 2014.  So far I never had any trouble and really enjoyed controlling my PC with an IR remote.

Edited by foobar
Link to comment
Share on other sites

I also have a URC remote (MX-900).  I used the Fire TV controller and programmed the remote and all the regular key presses work.  The Rewind and FF work for the short key presses (10 second skip), but I cannot get a long key press.  What do I need to do to get the long key presses programmed?  I bought the FLIRC specifically so I could get FF and REW on my URC remote.  The MCE remote / IR receiver I bought worked for the other buttons too, so the whole point of getting FLIRC was to enable the FF and REW buttons.

Link to comment
Share on other sites

Any thoughts on solving the press and hold for FF and Rewind on my FireTV?  I get continuous IR signals from my remote, checked on my camera, but the result is a series of 10 second FF or Rewind commands, depending on how long I hold the button down, rather than going into the true FF or Rewind that the AFTV gives with a long press.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...