Jump to content
Flirc Forums

flirc device or software not detecting any of my remotes button presses


Recommended Posts

Please keep me posted. It's not entirely impossible that it was me, but I can say with confidence that the amount of flircs I've sold, this has never been a problem. I wrote all the software included in the GUI except libusb, which is open source. There isn't anything malicious in there. The only thing I can think of is if the mouse/keyboard accidentally got the flirc driver. 


Again, keep me posted, happy to do a team viewer session to work this out.

Link to comment
Share on other sites

I have something similar going on. I had been using FLIRC with my Mac Mini and XBMC. Worked great. Ordered another for an Amazon Fire TV and in the meantime went to configure the FLIRC. I erase the configuration and had button assigned to all of my Harmony One. Unfortunately while the GUI said it was recording the keys in fact it wasn't. It kept mixing up everything. I was unable to get it to record F12 or any of the other keys I needed. It's as though after recording a few keys it would forget what was what. I tried forcing a firmware upgrade but that crashed my Mac in a big way. 


Is there a simple way to format the flirc so that it is as it came? Something really got messed up. I am using 10.9.2 on a Mini. 


I tried using the Panasonic TV suggestion but that didn't work. Trying to record play/pause kept shutting down the computer. So I reverted to your XBMC profile and filled in the rest of the keys with MCE stuff and made an activity with the Harmony. Used the remote when in that activity to record. That also failed.


Am at a loss here. It's as though the flirc just stopped working.



Link to comment
Share on other sites

ok iv restored windows back to pre gui install  and all is back to normal, but i simply inserted flirc device into the usb port (with no gui software installed) and windows has said drivers installed successfully but the exact same thing happened. Mouse ability was barely working and keyboard was very hard to function properly. So its not the software after all its just the flirc device itself causing problems, any advice on what to do? i have windows 7 service pack 1

Link to comment
Share on other sites

Try as follows:


Remove all flirc related content from the system (software and driver), if possible go back (again) to a restore point before the system's first contact with flirc.

Disable temporarely any running av-software during the following installation process to ensure a clean and error free installation of the software and especially the driver.

Some security software intends to interupt the driver installation and/ or try to put it into sandbox mode or isolates the driver partially etc.

So the best way is to disable the av software, install the flirc content and reactivate the av software to normal mode.

This behaviour depends on the functionality of the software you use.

After (re)installation of the flirc software and drivers plug in the device and wait for the recognition/ driver installation.

Now it should work as wanted.


I have installed the flirc software and drivers on three different machines with different windows versions (7/8.1 32bit/64 bit) without any hassle.

Also there were never any problems with av software (using kaspersky and avast av), except the described behaviour of sandboxing.

Nothing malicous found ever, the software is clean.


Some basic suggestions for programming the flirc device:


- Always program flirc in a "silent" enviroment, keep away any other ir related devices, which might interfere with flirc.

- Try to find the optimal distance between flirc and your remote for best responsiveness. Don't point your remote directly to the device. Try an angle of approx 45°

- Ensure to give flirc full usb power, plug it directly into an usb port from the mainboard if possible. If you're using hubs, the only active ones with power supply.

- Try to not use the "go"-button. Choose your Profile and bind the keys manually.

Edited by Nobuddy0816
  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...