Jump to content
Flirc Forums

Shield tv not working

Recommended Posts

Go my skip 1s today and I'm trying to get it to work with my shield tv and can't figure it out.  I added it to the activity and it automatically added it to the power on/off as well as most of the expected button.  But nothing seems to work.  I've got the activity working with my tv and receiver though.  It'll power both on and I also got it to change my receivers input to shield tv.  But the shield tv never turns on.  I tried controlling it after turning it on with the shield tv's remote and none of the buttons seem to work.

I've tried with the Shield pro 2019 and the old 2017 shield tv.

Link to comment
Share on other sites

Same here. Got my Skip 1s today and trying to get my Shield setup using Skip App 0.9.6 [master], but not having success. Plugged the Flirc USB into the Shield, chose Set Top Box -> Nvidia -> Shield Android TV and it didn't have any control over the Shield. What was odd was that pressing any of the Shield buttons on the remote would affect my LED lights (LX1 Bias Lighting with IR receiver). It could change the brightness and make it blink/strobe. So then I noticed there are Flirc entries in some of the categories. Under Flirc there are promising options:

  • Amazon Fire TV
  • Kodi
  • NVIDIA Shield Gen1
  • NVIDIA Shield Gen2
  • PLEX
  • Windows Media Center

The problem is that no matter what option I tried, the built in selections on the Buttons Panel are for some sort of fan. The buttons are for things like airflow speed, fan mode, oscillate toggle, temperature, etc.

First thing I need to get figured out is controlling the Shield + Kodi with the Flirc USB. Then I would like to figure out how to reliably control my LED lights so they can be part of the activity and turn on/off when I power the rest of my system. 


Link to comment
Share on other sites

I completely forgot the shield tv doesn't have an IR  receiver.  Tried the old flirc ir receiver but I noticed when I add it in the app all the button options look like they are for controlling a fan of some kind.  Which explains why it didn't power on my shield tv when I tried  the ir receiver before.

Link to comment
Share on other sites

Hi, any update on this? I just received my Skip and would love to set it up with my Nvidia Shield 2019 (w/ Flirc on firmware v4.9.6). I'm seeing the same issue where media buttons are not working for the "NVIDIA Shield Gen2" model.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...