Jump to content
Flirc Forums

Remote "Partially" Working with Flirc


Recommended Posts


Received my Flirc about a week ago, and I have mapped it a few times in the XMBC setting and I seem to have issues with only some of the keys working.

The remote I'm using is a programmable one provided by my cable company, but it is;

Universal Electronics


Rev. 3.0

The keys are very slow to respond and lag a bit, and I can only get some to work... For example, up/right will work but not left/down. That is about as far as I got as I know something isn't right due to the lag in the channel change too.

I am using it with WindowsXP, and I downloaded the latest Flirc.exe (0.97)

Any suggestions???


Link to comment
Share on other sites

I have a couple others... but do they have to be programmable? The other remote I have just has other inputs (TV, AV, etc).

In the Flirc utility, I tried mapping it on the MINIMALIST setting, and I noticed when you press the GO button it walks you through each button for mapping. I don't get the same thing with the XMBC setting. If I press the GO button it does nothing, and I have to click on each individual key with the mouse then map it with the key I want on the remote. This doesn't seem to be consistent.

Tried new batteries and got the same results.

Also, I tried reprogramming and using the minimalist setting... and I get the same results. Some keys work, so don't. For the ones that do work It seems you really have to hold it for a second for it to get it going, then they will be more responsive (eg. scrolling up).

I'm wondering if it is the firmware? It seems odd that it would "partially" work but not 100%.

In the utility, it says I have Flirc v0.96, and in the bottom left corner about the ERASE button it says Firmware v1

Any thoughts?


Link to comment
Share on other sites

Nope, they don't have to be programmable. Any other remote should work fine. You can even cycle through DVD/AUX/TV to get different remotes as those are most likely set as different devices. I'm not quite sure yet. If you give another remote a shot, that might narrow it down.

If you run through the GUI minimalist view two times, do you get, "button already exists" error? Or can you record the same button a couple times.

The "GO" button needs to disappear on the other windows, it only works on the minimalist window. I will update that in the next release.

Link to comment
Share on other sites

Hmm. I remember a similar thread.

This forum user was having a similar problem and reprogrammed a similar remote to another setting to control flirc.

I googled your remote control and came up with this PDF guide:


on page 61 there is some codes for samsung tv's. Perhaps you could give one of those a try to see if it alleviates the issue.



Link to comment
Share on other sites

Glad it's now working - hope you're enjoying FLIRC.

I have a harmony 300 (same as the 300i but not shiny - as a result cheaper). This is set as a panasonic tv for FLIRC control (as I have a samsung tv).


I like it, though the other models have more features.

Thanks for reporting back - helps us to help other users :)

Link to comment
Share on other sites

No problem! Glad I can help in anyway...

Switching to the Samsung setting seemed to have really helped the IR as well. I can point it in the general direction and not directly at the FLIRC, and the reception is great. Didn't change anything else with the remote so it has to be the settings.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...