Jump to content
Flirc Forums

Raspberry PI with OpenELEC


Recommended Posts

Hi everyone, 


I have a FLIRC for my Win 7 xbmc box and it works great. I recently installed a very recent build (XBMC 12.2) of OpenELEC on my Raspberry PI. I took the fully functioning FLIRC dongle from my Win 7 box and plugged it in to the RPI (before turning it on). I cannot get the device to recognize FLIRC and respond to my remote commands. 


I searched around and know people have this type of setup working, I'm just wondering if I'm doing something wrong. I've updated the FLIRC firmware to one of the recent Alpha builds (most recent I think) so everything is as up to date as I can get it. At this point I'm looking for any troubleshooting suggestions. Are there log files in OpenELEC I can look at? Anything that can tell me if the device is even recognized  I have been able to use USB keyboards with success so I know USB is working and a regular keyboard will work on my RPi. 


Thanks in advance for any help. 

  • Like 1
Link to comment
Share on other sites

Thanks for the reply. Sorry to say I have tried this already with no success. The RPi can be completely unplugged from power, FLIRC attached, and then powered on with the same result. I wish there was a light on the FLIRC, or a log file or something to let me know it is even recognized by the system.

Thanks again for the reply. Any other suggestions are welcome.

Link to comment
Share on other sites

Openelec's Raspberry Pi builds have ssh enabled. So you can ssh into your box.


ssh -lroot your.box.ip.address

​at the prompt type the following and press enter



the output of this command this will confirm if your flirc is being recognized.

Link to comment
Share on other sites

Thanks to kramer and Chris! for their replies. 


The lsusb command did show the device (I'm assuming it is the one showing up as "Clay Logic" as that does not exist when FLIRC is not plugged in). The weird thing was I can run the command twice within seconds of each other and sometimes the devices is there and other times it isn't. I grabbed the remote and hammered the up/down arrows and noticed that when the device does appear using the lsusb command I can get the menu to move up/down, but only once out of every 50 or so presses. The device seems to show up when usb devices are queried about 50% of the time. 


Moving on to power. I checked my power supply against the RPi requirements. It is 5V and 700mA as specified on the raspberrypi.org website. Would you suggest something with even more amps? What I'm using is just a generic cell phone charger from an Android phone, not the "official" RPi power supply cable you can purchase. I've read in a few other places that powered usb hubs sometimes make a difference when having issues with usb devices as well. Is this worth a try? 

Link to comment
Share on other sites

I believe it's the power supply. It's not just the voltage and current capacity that matters, but the quality. 

These small little power supplies are called switching power supplies. They turn off and on rapidly charging and discharging an inductor/capacitor.

The cheap ones have a lot of switching noise on what's supposed to be a stable '5 volts'. If you look at the output, you'll see it looks like this:




At any rate, try using another one. Because it's disconnecting leads me to believe it's definitely a power supply issue.

Link to comment
Share on other sites

  • 6 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...