Jump to content
Flirc Forums

FireTV Cube - Flirc - Harmony combination does not work

Adrian Toca

Recommended Posts


I recently bought a FireTV Cube and the plan was to control it with my Harmony 665. I had read on the web about the Flirc workaround to the native BT protocol used by the Cube remote and remembered that I have a Flirc G2 bought in 2017 still in the box for lack of an application. Plugged it in my Windows 8.1 and downloaded the GUI to program it. It first went on to upgrade the firmware to 4.9.3 (BTW, you may want to revisit the approach of popping up a message box with all the changes in the new firmware. The one I got was so tall that I had to struggle to reach the Yes button that was way below the bottom of my screen :-).

After that, I continued with the steps as indicated in the forums:

  • Programmed Flirc selecting the Fire TV controller and the FireTV built-in Profile
  • In MyHarmony, I added Flirc Media Player [Flirc FireTV], then went on to assign the Flirc buttons to the remote buttons
  • Set ADB Debugging to OFF in the Cube's settings
  • Plugged Flirc in the OTG cable and the cable in the Cube dongle

Unfortunately, it does not seem to work and was wondering if you could help me troubleshoot it. Did I do something wrong in the steps above? Is there a quick way of figuring out whether there is a problem with the unit? It seems to be responsive, I have not gotten any error messages.





Link to comment
Share on other sites

Step 2 - I tested the OTG cable by inserting it into a phone and a USB stick in the female connector and it played music on the phone off the stick. So, both Flirc and the OTG cable are fine.

Then I took it to the FireTV and inserted it in the dongle with the USB stick still attached. The image on TV started to blink every second or so, so there is some activity, but not sure what to make of it - either the Cube does not accept Flirc or the cable's wiring is incorrect, which I highly doubt.

Link to comment
Share on other sites

What else I tried: inserted the OTG cable directly in the Cube and tested with a keyboard, then a mouse, to see if the USB interface works; using the keys or moving the mouse I tried to move something on the screen. No luck.
Today, I got the SMAYS (https://www.amazon.ca/gp/product/B08D6H7Y85/) from Amazon and - after feverishly inserting both Flirc and network cable in it, it works, I can now use my Harmony to move around the Cube.
So, the only conclusion is that there is a problem with the Amazon-provided dongle. Inserting the OTG cable directly into the Cube is not a proper test either.


  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...