Jump to content
Flirc Forums

gen 1 and gen 2 flircs both don't work after reprogramming with Kodi on ubuntu


Recommended Posts

I had the original flirc which worked flawlessly for years.  I recommended it to many people.  I decided to reprogram it for another remote and I got that virus message that people talk about, but I figured that was false, so I went ahead and upgraded the firmware and reprogrammed the new remote.  It didn't work, so I went back to the original remote and that doesn't work now either.  So I figured the flirc was old and tired and ordered a new one.  Same thing happened with the new one, it doesn't send keystrokes reliably.  I tried it with about 4 or 5 different remotes. Sometimes it works a bit, other times it's as if I've not pressed any buttons.  I also feel like customers problems aren't being acknowledged by Flirc.  This problem has been reported many times for about 3 years yet it never seems to get fixed.  I'm thinking the only way out of this problem is to revert to the old firmware.  Can you send me the original firmware for the gen1 and firmware that will work with the gen2?  Thanks. I've been struggling with a dysfunctional remote for so long and pulling my hair, I'm ready to throw both of them in the trash.

Link to comment
Share on other sites

The virus message is still there? Did you try the most recent download?


make sure you are downloading from: http://www.flirc.tv/support

Any idea what firmware you were using before? A little more info about the problem would be helpful

In advanced. Enable IR logging (on the second generation). Press and hold a few buttons and post that here. 


Link to comment
Share on other sites

Hey Jason. Thanks for responding. Sorry. That my message was unclear.  No, the virus message was on a windows machine.  Since then I've reprogrammed the remote using Ubuntu and I want to use the remote with kodi on Ubuntu 20.04.  The GUI prompted me to upgrade from whatever was on the flirc.  On the new Flirc the firmware is 4.9.3 and the GUI is v3.25.3.  I tested the volume and up down keys and the play key and attached the log of the output.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...