Jump to content
Flirc Forums

Need to press every button twice


Recommended Posts


I use Flirc v2 together with a Logitech Harmony One+ on Debian Buster (10.4) and MythTV.

On the Flirc I have selected a full keyboard layout.

The problem is that I need to press every remote button twice for the command to work.

Before I bought a Flirc I used ir-keytable and did not experience this problem.

Any help or suggestion would be appreciated.

Best regards,

Link to comment
Share on other sites

Interesting, I thought it was just me and my old Hauppauge 45 button remotes.  Assuming it's the same issue I have it goes back 7+ years (see my post from 2013). 

I thought there was a fix for it at one point, but maybe not officially released.  I just tried setting up a gen1 Flirc with the H45 remote again today and am having the same issues.

I too am using ir-keytable with the H45 remote on my ODroid N2 (with built-in IR) running CoreElec with no issues.  The N2 is probably over-kill for Kodi, but man is it a rocket!  The ODroid C4 (also has built-in IR) appears to be very comparable to the RPi4 and if I don't have to buy the Flirc (and a new remote) it would be a fair amount cheaper solution too.

Link to comment
Share on other sites

  • 1 month later...
  • 5 months later...
  • 1 month later...

Same here. I would like to use my Flirc 2.0 [dori] with a Zotac remote, but it only reacts to every second keypress.

# evtest --grab /dev/input/event3

[First press]

Event: time 1613386729.571849, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70027
Event: time 1613386729.571849, type 1 (EV_KEY), code 11 (KEY_0), value 1
Event: time 1613386729.571849, -------------- SYN_REPORT ------------
Event: time 1613386729.700038, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70027
Event: time 1613386729.700038, type 1 (EV_KEY), code 11 (KEY_0), value 0
Event: time 1613386729.700038, -------------- SYN_REPORT ------------

[Second press -- Nothing]


Link to comment
Share on other sites

  • 1 month later...


I have the same issue with my XBox 360 remote, but this seems to be a known issue with some remotes with a really simple fix. You just have to program the same button twice. The issue seems to be because some remotes do actually send alternate codes with each button.

When I program my remote to for example sent Ctrl-P to my HTPC, I use the Flirc program and press Ctrl, then P in the GUI and then press the "Play" button on my remote. The program confirms the button was recorded. Then I do it again, and once again, it confirms it was recorded. At this time I am done and the Play button will always send Ctrl-P to my HTPC.

If I did the same thing 3rd time, it would say that the key has already been programmed.

Have you tried this?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...