Jump to content
Flirc Forums

Flirc doesn't respond to RC commands


Recommended Posts

A long time ago I wrote to you for help, and Mr. Chris and Mr. Jason were very kind to me.

I have Windows 7 x64

Well, I have these two Flircs (you all sent me one of them for free back when I had troubles the first time) and they are a bit old; I think from 2015.
I have installed the latest Flirc GUI and upgraded the firmware on my Flircs from 3.6 to 3.9.  You can see that Flirc has the 3.9 driver.

Neither of my Flircs respond to the remote control's commands.  I can program the buttons just fine in the GUI
But I'm getting this in the device log.


In the Windows 7 Device Manager I see under Portable Devices the WPD FileSystem Volume Driver is in a warning state with "This device cannot start. (Code 10)".  I tried uninstalling these drivers and re-inserting the Flirc, but it comes back to the same situation.

I also see the Flirc Driver there under libusbK USB Devices; I tried uninstalling this too and deleting the device drivers.

Is there something I can do?



screenshot_Microsoft® Windows® Operating System (Microsoft Management Console) [mmc]_003.png

screenshot_Microsoft® Windows® Operating System (Microsoft Management Console) [mmc]_006.png

screenshot_Microsoft® Windows® Operating System (Microsoft Management Console) [mmc]_007.png


Edited by bgmCoder
added screenshot of Device Manager
Link to comment
Share on other sites

20 hours ago, bgmCoder said:

So I tried a third USB port and Flirc works on the third port.

It's just borked on the first two USB ports.  I'd like to fix that!

Windows is really funky like that. Sounds like it installed the driver correctly for one port, but the other ports got messed up.

You can try uninstalling the drivers in device manager, and let windows set that up again for you.

Let me know if that helps.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...