Jump to content
Flirc Forums

Button clicks are not recognized by the flirc gui keyboard


Recommended Posts

I'm not sure what happened - it *was* working...

but in the FLIRC GUI, when I enter keyboard mode,

when I click on win, alt, or ctrl keys (mod keys) they are not being recognized.

I mean that the keys don't turn green like they are supposed to.

other, non-mod keys work fine.


How do I fix this?

I've tried stopping and starting the gui.

Edited by bgmCoder
Link to comment
Share on other sites

Never mind - I used the commandline:  flirc_util.exe dfu

and that fixed it.

It erased all my pairings, but it will record again.


I think what had happened is that I used the flirc gui's "Force FW Upgrade" to see the firmware version, but cancelled out.

It put the upgrade status into "error"

and after that it was broken.

So it seems like cancelling out of the "Force FW Upgrade" window has a teeny bug somewhere.


Finishing the upgrade fixed the issue.



Uh, no it's still broke.  it worked for a moment, though.

So I used "clear configuration" but that doesn't fix it.

Edited by bgmCoder
Link to comment
Share on other sites

Well, it's recording the mod keys now, but it thinks that 1 is !

It's as if the buttons I push on the gui keyboard are not registering correctly.


The gui says its pairing with lwindows+1 but flirc_util.exe keys says that is +left_cmd+!





okay, now it lets me record, but it never sends anymore.  sigh.

C:\Program Files (x86)\Flirc>flirc_util.exe keys

Recorded Keys:
Index  hash        key
-----  ---------   ---
    0  6C7ADFBB    +left_cmd [
    1  473E5042    +left_cmd ]
    2  A4DBB3ED    space
    3  7F9F2474    f
    4  F9167BBB    +left_alt 0
    5  1E530B34    +left_alt 0
    6  686077A6    S
Edited by bgmCoder
Link to comment
Share on other sites

I plugged it into a different USB port that it had never used before and it started working.  This reinstalled the driver for that port.  Somehow the driver must have borked on the first drive.  So I thought I'd try it in the other drive again, it didn't work there, and when I put it back in the second one, it stopped working there too.


So it seems to be a driver problem.  Windows 7 x64.


When I look at it in Nirsofts USB DeView, it is like this:


0000.001a.0000.    flirc    Vendor Specific    Yes    Yes    No    No            6/2/2015 3:23:05 PM    6/2/2015 3:23:06 PM    20a0    0001    1.00    ff    ff    ff                        libusbK    libusbK USB Driver 12/25/2013 -    libusbK.sys    libusbk devices    Flirc Inc    100 mA    1.10    flirc    USB\VID_20A0&PID_0001&MI_01\7&2f3fd6ab&1&0001    


So I uninstalled all the flirc entries and when I plug it back in it reinstalls and then works.

But if I unplug it and plug it back in, it does not work.

Seems like I have to reinstall the driver to get it working again.


Edited by bgmCoder
Link to comment
Share on other sites

Hi, Chris.  I sent an email via the page just this morning, in fact.


I've even used Geek Uninstaller to remove Flirc and its regristy entries (which are not removed by the installer, by the way).

Then I used Nirsoft USB De View to uninstall the usb entries.

And reinstalled.

But it's still borked!

I bet you all must be pretty busy with all this.


I've force-upgraded the firmware via the gui.  I've used Zadig to resintall the libusbk driver for flirc interface0 and flirc interface1.

The computer knows when I plug it in, Flirc GUI knows when its connected, and I can record keys now, but it can't play them back in the GUI, and the remote doesn't work (although it did at first just fine).

And it's still borked.

So, I'm looking forward to hearing from Jason!

Link to comment
Share on other sites

Well, I'm starting to lose hope! I sent in my support request and have received no reply.  My Flirc is borked and now my hopes are borking.


I think I would like to try a different driver.  Some of the forum threads talk about using a different driver, but I can't find any way of getting an older version.  Too bad there's not a list of old drivers than we can download.  It's the only thing I haven't tried - because I can't!

Edited by bgmCoder
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...