Jump to content
Flirc Forums

Brand new Flirc & software crashes on launch


Recommended Posts

I've got a brand new flirc usb dongle (arrived yesterday). I connected it, downloaded the application, updated the firmware per Flirc's blog, and now the software crashes on launch.

I tried manually updating the firmware as recommended in the sticky note of the firmware forum. That didn't fix it.


I uninstalled the driver and application completely, rebooted, and reinstalled. That didn't fix it.

My brand new flirc is dead. Is there a fix, or do I just need to return it for a refund and find some other IR receiver?

Link to comment
Share on other sites


Can you tell us more about your PC? Which Windows version and on what hardware it's running on. Which USB port version/type.

Do you have access to a different PC to which you can connect Flirc instead to check if it's working?

Link to comment
Share on other sites

Brand new PC, custom built this weekend. Fresh install of Windows 10 64-bit, upgraded from a clean install of Win7 64-bit Home User. Hardware is Intel Core i5 6500, ASRock H170 Pro4 motherboard with USB3, and a Samsung EVO 850 500GB SSD (and other various pieces).


I initially connected the Flirc. Then I found the GUI app download page, installed it. It launched. Then I ran the Force FW Upgrade from the app. That seemed to run, and then the app crashed. Subsequently the app crashes on launch.

I've tried:

* Reinstalling the app

* Uninstalling app and drivers, and then manually updating the drivers from the app's driver directory.

* Running the Zadig approach described in the ZenDesk forum, but the process doesn't match what I see in Windows 10, so I didn't proceed.


I haven't tried the installation process I just found, which is to install the GUI first and then plug in the USB dongle.


Thanks for the help. Sorry I was "short" in my initial post. Two days of PC build, including 4-6 hours lost on Win7 updater failures...and then get past that to find the Flirc receiver died on installation. I was frustrated :)

Edited by ShoutingMan
Link to comment
Share on other sites

Until Jason finds out what's happening recently with Windows 10 you would need to get access to another PC with Windows 7 or Linux. I think running those as virtual machine (in VirtualBox for example) would also work after setting USB pass-through for Flirc to be connected to guest machine instead of host.

After that Flirc should work properly in Windows 10 as it doesn't need Flirc software to work (its only required for programming).

Link to comment
Share on other sites

Flirc is basically operational after updating on a Mac.

After the Flirc app on my Mac updated the Firmware on the Flirc, I cleared the settings. 

I programmed my Logitech Harmony One to control the Flirc using Kodi settings (http://mymediaexperience.com/flirc-remote-control-companion/).

On the Win10 PC I downloaded and reinstalled the Flirc app, launched it, and then plugged in the Flirc. That worked fine. I quit the app.

I ran PowerDVD 16 and have basic control of it with my Harmony One and the Flirc.

Link to comment
Share on other sites

That's great :). You don't really need the Flirc software on the target system. As I've mentioned before, you only need Flirc software for programming/configuration. After that Flirc emulates an USB keyboard, so you don't need any extra drivers to control PC or any other device that can be controlled with a keyboard.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...