Jump to content
Flirc Forums

Issues with Logitech Harmony 525, Plex, Win7 and Flirc


Recommended Posts

I received a Flirc yesterday for my home rig and have had a variety of issues.  

Initially I installed the GUI, plugged it in and it showed connected. Drivers seemed OK, could see in device mgr. Smiley green Flirc face.

Tried programming keys with the GUI - no response when using remote

Tried adding Flirx-XBMC in Logitech - no response

Tried all combos - gui + logitech, just GUI, just Logitech, none - all no response

Rebooted windows, started working perfectly.


Went to bed, W7 machine goes to sleep overnight.

Turned on Plex today, remote not working at all.

Tried all of the above again, at one point seemed the remote was spamming keystrokes at Flirc so I opened a text doc and sure enough keystrokes typing across the page.  Plugged stuff in and back out, tried lots of combinations of things, at one point it sort of worked by with about a 7 second delay.  But then it stopped entirely again.

Later I removed everything, including drivers and started all over and rebooted and it was working.

I called my wife and said hey look its working and gave her the remote - and it had stopped working.   Pressing the right direction arrow about 10 times made it move at one point, and I said 'see!' but she was not impressed.


I dont know what to do next.  I dont really want to have to do a fresh install of everything every time I want to use it!  Wireless keybaord isn't that annoying that I want to subject myself to all this.  I'm suspecting Windows is to blame.  I have Apple stuff everywhere and use to use Mira USB for driving my Macbook media centre, that worked out of the box and never required any tweaking.  But have a Windows laptop now so Mira no good so bought a Flirc.  


Sorry for disjointed post, but I am seeing disjointed issues and the vendor support I bought the device from stopped replying to my emails earlier today.

Link to comment
Share on other sites

Let's try a couple things before getting you a replacement. 

Do you have the TV or lights on while recording. Flirc is so sensitive, it could  be picking up a bunch of noise.

Make sure you on firmware version 3.6, head to the Flirc GUI, go to advanced, and do a force upgrade.

When you see the bootloader version as it upgrades, can you let me know what it is? Should be 2.0 or 2.1.


Once the upgrade is complete, do a file->clear configuration. Then start over.

You should not have to reinstall drivers for this to work correctly. It shows up as a USB keyboard, so it's not necessary at all. Let me know if the latest firmware helps. I'll get it worked out, shouldn't be this painful.


Link to comment
Share on other sites

Thanks, I will try all of that.  One thing to clarify, do I need to have it as a device in the Logitech as well as recording the keys? Or should I remove it from the Logitech devices and just have it as as a remote keyboard?

Ie. configured in

1. Logitech software + Flirc software

2. just Flirc software 

3. just Logitech software


4. Something else?!

Link to comment
Share on other sites

I am on Firmware 3.6, did a force upgrade, bootloader was 2.1


Yesterday I put new batteries in the remote, turned off wifi, took the laptop and remote out to the back yard to remove chances of interference, cleared config and tried some key mapping.

I click on a virtual key it says push a remote button - no amount of pushing buttons on the remote would cause anything to happen.  Tried for about 5 minutes.

I also tried with and without the USB extension cable I'm using to rule that out - made no difference.  Holding the remote against the Flirc directly in the USB port still no good.


Today I tried the exact same steps and it worked.  I was able to program buttons and as of right now it is working just how I want it to with Plex and my other components.  I'll try again later and see if it is still working - the pattern so far suggests it will not be working, just been seeing random behaviour.  Really hard to diagnose and really frustrating!

Link to comment
Share on other sites

So I now have two units.  With the second unit last night I upgraded firmware, added Flirc/XBMC in Logitech remote, configured all the buttons in the Logitech, then configured the buttons in the Flirc app.

Everything then worked perfectly - i mucked about with it for an hour or so, no troubles.

This afternoon after work I turned everything on and initially it didnt work, but then after 30 secs or so it started slowly responding and within a full minute it was working again.  Like it had been asleep.

A few hours later I turned everything on again to watch a show - and it appeared it had stopped working.  I tried for a few minutes but was getting nothing.

Just now I tried again and was getting nothing still, but then I pressed and held a button (up arrow) and after about 1-2 secs - it moved up, but 2 or 3 rows.  I tried this with other buttons and it seems to be doing this with all of them.  if I hit say right arrow then nothing happens for a second or two and then it jumps a few rows to the right.  


So still not usable, but does it sound like anything you have seen before?


Edit - the laptop going to sleep seems to be the trigger for it not working.  I've seen a few threads around this dated over the past few years, but is there a fix?


2nd Edit - This morning it is working fine again! Laptop went to sleep over night, I didnt change anything after last night when it was misbehaving.  Intermittent problems are such a pain!

Edited by bloodygeoff
Link to comment
Share on other sites

Back to not working - sometimes not at all, sometimes just a few keys not working, or unusable delays.  Anyway, I think I've seen enough and not finding any answers so I'll send it back.

Could very well be the usb port in your laptop. Maybe it's ultra noisy, or under powered. If you had a hub, you can try that. Otherwise I'm really not sure why it would be acting up. I've never heard of this misbehavior and I'm really very sorry for all the trouble. 


You also shouldn't need to program or pair xbmc keys, they are pre-pared with the flirc. Just add the xbmc harmony profile, and that should be it. Make sure you are on the latest firmware which is 3.6.


Again, really sorry about all this. = (

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...