Jump to content
Flirc Forums

Attempting to Troubleshoot


Recommended Posts



I've purchased two flircs to be used in two machines -- Both have the same hardware. When I initially installed the flirc it worked just fine, after upgrading the firmware (I know.. why upgrade if it's working fine) it has stopped functioning. It WILL allow me to record the keys in the GUI, however, after recording they are not actually being sent over according to the GUI. (e.g., after the GUI displays a successful recording, the actual key press afterward is not shown). 


I have attempted the driver fix according to the support page, manually and using the tool. I've attempted using the newer GUI and forcing a firmware upgrade again, also multiple USB ports on this machine. 


Now.. I got a second flirc, it exhibited the same behavior on this machine. 


I took one of the flircs and installed it on a laptop running the same operating system (windows 8.1) and it worked flawlessly. Tried in another computer and again, worked like a charm. So now the issue is that it will work in every computer EXCEPT the one that it needs to work in! LOL. 


I've spent numerous hours looking into this and i'm simply out of options -- Can anyone provide any insight as to what I can to do get this working on a machine other than my laptop? Note that it WAS working out of the box, only stopped functioning correctly after the FW upgrade to 3.4


Thanks in advance to any help, I've purchased these from Amazon but simply cannot get anywhere from information readily available. Thanks again. 


Link to comment
Share on other sites

Thanks for the info and helpful topic in the knowledge base. 


Jason/Chris - I'm not sure why, however, windows is not defaulting to the HID keyboard driver for interface 0 -- I'm attempting to force this, but not looking like it is happening. 


I'll continue to troubleshoot. 

Link to comment
Share on other sites

Alright - I'm not sure if its working yet as I'm not home, however, the device settings in Windows 8 are setup as they should be. I'll update this post tonight after testing. 


For the benefit of the thread what I did was as follows: 


1. Enter properties of interface 0 and Interface 1 in device manager

2. Click "Drivers" tab

3. Click "uninstall" and also and probably what made the difference, click the checkbox for "uninstall driver software" -- Click OK

4. Scan for new hardware 

      A. for me in this instance interface 1 was setup appropriately and interface 0 had a mark indicating it had no driver installed. Right click and install driver, select to browse for driver and select "USB Device" -- After clicking OK it installed as a HID Keyboard. 


Will update tonight after testing. 

Link to comment
Share on other sites

I'd suggest adding a note to the KB in the Windows section concerning uninstalling the drivers when you see interface 0 showing up with libusbk -- Must click the checkbox that says "uninstall driver software" when uninstalling. 
Anyways - Thanks for the comments - Great device.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...