Jump to content
Flirc Forums

Firmware upgrade failed, now GUI crashes on start and Flirc doesn't work


Recommended Posts

Today I tried to upgrade the firmware as per instructions here: https://flirc.zendesk.com/hc/en-us/articles/201130296-How-Do-I-Upgrade-My-Firmware-

The Gui showed that firmware was 1.0, I used the button "Force FW Upgrade", it showed that the new firmware is 3.? something, iirc, I confirmed and it started upgrading, then it failed and crashed the flirc Gui. Now the flirc Gui crashes straight away, when I try to launch it. I tried to uninstall and reinstall Flirc software, it did not help - same thing happens. Oh, and flirc/remote does not work at all.


Please, help, what should I do? Is my flirc completely f***ed?


The system, on which this happened:

Intel NUC D54250WYKH1

Windows 8.1 Pro x64

This nuc is brand new - a couple of days old, just bought it last week. It only has windows, chrome and XBMC installed on it, and that's it. If you need any more info, let me know.


Thanks in advance.


Link to comment
Share on other sites

  • 2 weeks later...

Unfortunately It appears that I have the same problem as cryodream.  I attempted a firmware update as per instructions and the update failed leaving the flirc dongle unresponsive to the gui.  Tried to install on another machine but no luck.  Original firmware was 2.3 and was ready to update to the 3.x  Shows up in device manager as "flirc bootloader" but gui reports "disconnected".  Any suggestions will be greatly appreciated

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...