Jump to content
Flirc Forums

FLIRC from Amazon refuses to recognize remotes or update firmware- advice?


Tassyr
 Share

Recommended Posts

So yeah, the title. I got one off amazon for use with OpenELEC- it arrived a day or two ago, so I sit down to program it on my pc. (Win764.)

 

and that's as far as I've gotten. NO remote used will recognize. In an attempt to figure that out I decided to force a firmware update. At best it'll get to 1/3 progress bar, lock, and sit there in definitely.

 

Help?

 

(Additional info; the program can detect when I've plugged in the FLIRC device, but not when I've removed it. Odd.)

Edited by Tassyr
Link to comment
Share on other sites

OK it seems that it's not flashed correctly. Close the GUI and open it up again when the Flirc is already connected. Does it ask you if you want to upgrade the firmware? If not try again using "Force firmware upgrade" in advanced options.

 

Do you have access to another computer to try firmware upgrade on it?

Link to comment
Share on other sites

Question. I MIGHT have a friend who can donate a really, really old laptop that barely runs xp for this. Will I be able to run things from that?

 

Got the laptop, got both the 0.96 and 1.3.0 versions installed on it.

 

The .96 sees the device as connected and the firmware as v2.3 but has no force update mode.

 

The 1.3.0 does NOT see the device, says it wants to update firmware, and promptly locks up indefinitely again.

Edited by Tassyr
Link to comment
Share on other sites

It's definitley something with windows. It's not able to read the version correctly and then most subsequent commands are probably failing. Close the gui. Unplug Flirc plug it back in and try again. I'm really sorry, there are some instances with windows this happens and I can not reproduce it. Maybe I can send you a version that will give me logging information if the above does not work. Let me know.

Link to comment
Share on other sites

It's definitley something with windows. It's not able to read the version correctly and then most subsequent commands are probably failing. Close the gui. Unplug Flirc plug it back in and try again. I'm really sorry, there are some instances with windows this happens and I can not reproduce it. Maybe I can send you a version that will give me logging information if the above does not work. Let me know.

So yeah, NEITHER computer, after a reboot, different USB port, and clean reinstall each, simply refuse to work. Hell, if it were my laptop I'd just mail you the thing; it's almost ten years old.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...