Jump to content
Flirc Forums

Recommended Posts

Hi all,


I’ve just gotten my Skip1s and USB bundle. Really excited and trying to get things set up, but I’m running into a problem I can’t seem to solve. 


Issue: Can’t control Plex via Skip1s as programmed in Skip app


Set up: 

  • Skip1s programmed “PC” for “Flirc” and “Plex” in Skip app v0.9.956 beta. Synced to “A” Activity button
  • FLIRC USB and software v3.27.10
  • Windows 11 Pro
  • Plex HTPC v10.0.22631



  • Controls as programmed via the settings synced from Skip app to “A” activity don’t trigger the expected behaviour in Plex. 
  • I am able to program some aspects of Plex controls with Skip1s via FLIRC USB software, but not all (so obviously not desirable long term). 
  • When no settings are programmed in FLIRC USB software and the device log is set to “Enable IR Debugging”, IR signals from Skip1s are detected. 
  • Activity “B” settings for TV and Soundbar work as programmed in Skip app. 
  • FLIRC USB doesn’t show in Windows Device Manager, including, hidden devices. 


Attempted remedies:


  • Full system restart
  • Powered Skip1s off/on via removal of batteries for >10 minutes
  • Moved FLIRC USB to multiple alternative usb ports, including a usb hub, front panel and mobo backplate I/O.
  • Program desired settings to activities “B” and “C” via Skip app
  • Reset Skip1s settings in Skip app, used Skip app on alternative windows machine to set up Skip1s as a new device. Used FLIRC USB and software on alternative machine. 


Outcome: Issue persists, namely, input via Skip1s remote results in no action in Plex. 


Any help/suggestions would be greatly appreciated. I love this product already, I just want to make this work and it’ll be perfect. 

Edited by Rgratton
Link to comment
Share on other sites

19 hours ago, Rgratton said:

@jason @Nathan I’m sorry for the ping, I just haven’t had a reply to above post from 26 hours ago. 
I normally wouldn’t ping but I was concerned the post may have fallen through the cracks given newer posts have had replies from Admin. 
Any help would be much appreciated. 

I'm fairly sure Plex HTPC uses the same controls as Kodi. Have you tried opening the Flirc software, changing the controller to Kodi, and programming using those keys?

Link to comment
Share on other sites

Thanks for the suggestion Nathan. 

Similar issues present themselves on Plex HTPC using  ‘Kodi controller’ via the Flirc USB GUI, as they did with ‘Keyboard controller’.

Biggest issue is not being able to return to show page/home etc after an episode ends, neither pressing the programmed “home” or “go back” keys work. I can hear Plex registering that there is an input but it goes nowhere. 

Plex HTPC doesn’t have an onscreen home or go back option either, so I have to get it to work on remote.

There are a few lesser pet peeves, like not being able to program a key for subtitle and audio track changes, but they’re easy peeves to live with in comparison. 

Since posting originally, I’ve also tried in Skipapp adding the Plex as “Other” > “Flirc” > “Plex”, but still no joy. 

I’ve also tried “PC” > “Flirc” > “Kodi” and also “Other” > “Flirc” > “Kodi” just as a troubleshooter step, and it’s a similar result as using the Flirc USB GUI. 

So maybe the Plex integration via Skipapp is borked?



Edited by Rgratton
Link to comment
Share on other sites

  • 3 months later...

I had to use the Kodi profile for Plex HTPC. Most buttons work, but home is missing. To program a button for home, just add a random unused Kodi action to the home key on the remote (I used the colour Blue, which is F4 I think), sync that, then map that button to the "h" key in the flirc USB app. You can do the same thing for subtitles etc. just line things up with the plex keymap.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...