Jump to content
Flirc Forums

FLIRC won't wake computer


Recommended Posts

Hi guys.


I have a question. I recently purchased an ASUS Chromebox M004U, which I set up with a fresh install of Ubuntu 14.04. Using a Harmony Smart remote, I can pair buttons using the FLIRC application perfectly, and I can use the Ubuntu keyboard settings to bind a FLIRC key press to suspending the computer (via "sudo pm-suspend &"). My problem is that regardless of what computer keys I bind a FLIRC button with, the FLIRC receiver will not bring my computer out of suspend. 


I have tried using the same USB port with a wireless keyboard and mouse, and in both cases I can manually enable USB wake up by using


 "echo enabled | sudo tee /sys/bus/usb/devices/1-2/power/wakeup"


However, this same strategy does not work at all for the FLIRC receiver when it is plugged into the same port. Enabling the entire hub (replacing "1-2" with "usb1") causes the computer to come immediately out of sleep. I believe this is from the bluetooth or other built in modules being attached to the USB bus.


I don't know how important this is to my particular issue, but I forced an upgrade to the most recent firmware (2.6), and tried enabling sleep awareness in the advanced options. Neither change had any effect.


Does anyone have any ideas that might help me sort this out? Any help would be greatly appreciated!

Link to comment
Share on other sites

No problem. I'm trying to decide if I should keep it right now or have it so any key wakes the machine. I'm struggling with this a bit as I see too many people accidentally waking their machine. Sorry for the trouble and I'm sorry this wasn't more obvious.

Link to comment
Share on other sites

Thanks Jason, that did the trick! Can't believe I went through all that trouble and didn't realize there was a built in wake button.

I have been having issues getting my zotac to suspend and wake up using the flirc device.


Would you be able to provide the steps you followed to get it working?


I am using xbmcbuntu I also tried enabling wake on usb on the usb ports but that didn't seem to work for me.

Link to comment
Share on other sites



No problem, I'm just glad I didn't spend too much time digging deep into the device wake options. Would it be possible to switch between the two modes in the advanced options? Right now with my Harmony I could see wanting to use any button since the buttons take a pretty hard click to activate, but I could see it being a problem with more sensitive remotes, so a single wake key would be better there.






I binded a key on my Harmony remote to the Flirc Wake command (which is on the full keyboard configuration, top right area). From what Jason says it seems the current Flirc firmware only listens for this particular command rather than any button press like a typical mouse or keyboard. The command I was using in my original post to make the Flirc port a wake up device was actually fine in my case, The problem was that I assumed any Flirc key would wake up my computer, rather than the just the "wake" button.


Have you tried to enable/disable with a keyboard/mouse that you know normally works as a wake up device in the same USB port you're using for Flirc? I did this as a quick test just to make sure that Ubuntu was actually responding to my USB wake up changes.


Just in case it helps though, here's a list of everything I did:


1) add "tee" command to my sudoers file so that it does not require a password when run with elevated privileges (this is not good practice, but for a media computer that I don't want to pull a keyboard out for it seems the only option)

2) add "echo enabled | sudo tee /sys/bus/usb/devices/1-2/power/wakeup" so that the USB port is automatically enabled at startup

3) Bind Flirc key "ctrl+alt+z" to a button on my Harmony (i.e. Guide)

4) Bind Flirc key "Wake" to a button on my Harmony (i.e. Menu)

5) Make Ubuntu keyboard shortcut "ctrl+alt+z->sudo pm-suspend &"

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...