Jump to content
Flirc Forums

Disabling Wake From Sleep


Recommended Posts

Thanks! Just did a quick check with

flirc_util.exe settings

And noticed what your talking about...

    5  33733D53   045  02  next_track
    6  CF881170   130  01  up
    7  2C2DDF24   045  01  up
    8  D1B6D3EB   045  01  left

#6 does seem like the odd one out of the rest of the codes, I tried to delete it with

flirc_util.exe delete_index 6

But it doesn't seem to take effect as running the settings command shows it.

Is there another argument that I should be using or could you please remove it?



Just noticed this one...

12  10A01061   045  01  0

Not sure if that was from you or not, but if not it could likely be removed as well.

Edited by thekaptn
Link to comment
Share on other sites

19 minutes ago, thekaptn said:

Hey Jason, was able to kill that mapping using the UI. So far everything seems to be working great! Again, appreciate the assist!

My pleasure. Yeah, looks like I have a bug in the command, so sorry about that.

On my list is a bit of a firmware re-write to bring it up with the remote as well as make the configs human readable JSON. 

  • Thanks 1
Link to comment
Share on other sites

@jason, I noticed over the weekend that things weren't 100%.  When applying the profile you gave it seemed to work because I had every device that was listed in...

powercfg -devicequery wake_armed

...and then disabled it via...

powercfg -devicedisablewake '$DeviceName'

...so when I applied your fix, the keyboard was disabled from waking, so it didn't wake the PC.

However, after enabling it with...

Enable-WakeForDevice -DeviceName $deviceName

...The remote is waking the PC again through the Flirc when it is sleeping. I confirmed the only device listed as wake_armed is my logitech keyboard that is connected via the unifying USB receiver.

Any suggestions on how to only have my logitech keyboard wake the PC?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...