Jump to content
Flirc Forums

[win8.1x64] Clicked upgrade firmware, software crashed and flirc now bricked?


Recommended Posts



I recently received a flirc and after installing decided I should upgrade the firmware from v1.0 to that suggested by the flirc application (v2.4 if memory serves). The operating system I used is Windows 8.1 x64 and I used a usb3 port (I have no usb2 ports on the machine). After clicking upgrade the application immediately crashed and under device manager is now only listed as bootldr with a yellow exclamation mark indicating the drivers for this device are not installed. Each attempt to run the application after this resulted in an immediate crash.


After waiting 10 minutes or so (just in case!) I unplugged the flirc and plugged it into my Windows 7 x64 machine in a usb2 port and installed the flirc software. Unfortunately it also could not load drivers.


Has this bricked my flirc? Is there a way I can recover from this? I have a linux machine I can use if that will make a difference.


This is incredibly frustrating - I didn't do anything untoward, just attempted to update the firmware using the supplied application.

Link to comment
Share on other sites

I ended up buying another couple of Flircs. I attempted to upgrade one of the new Flircs on a separate PC running Windows 7 x64 on a USB port and experienced a similar issue.


Screenshots of the device manager from the two PCs:

udEcIQx.png hWC0IFO.png


If I start the Flirc application on the Windows 8.1 machine with the Flirc plugged in it immediately crashes. USB drivers on both machines are up to date.


The Windows 8.1 machine on which I did the initial upgrade recognises both non-working Flircs as "flirc bootloader" under libusbK USB Devices, while Windows 7 recognises them both as "bootldr" under Other


Edited by cardboardpig
Link to comment
Share on other sites

Jason, after reading your email I decided to use a third machine running Windows 8.1 x64 and a fresh install of Flirc to try the upgrade from a different USB chipset.


I was unable to upgrade the Flirc initially, but after uninstalling and reinstalling the Flirc software a second time (and deleting drivers) I was able to upgrade the firmware... I didn't change anything between the first and second attempt so I'm not sure why it worked the second time. I was able to fix the second non-working Flirc the same way. The same procedure didn't work on the first two machiens.


Furthermore as the USB drivers on the first two machines were fully up to date I can only assume the Flirc and their USB chipsets/drivers just don't get on together when updating firmware...?!

Link to comment
Share on other sites

  • 5 months later...

This has just happened to me as well, and i am running the latest drivers for my newly built htpc machine.


I have tried to uninstall and reinstall both the drivers (by right-clicking the device, choosing to un-install, and ticking the delete driver option), and the software, with reboots in between, and it has not helped.


I see the device in my device manager, but the software crashes immediately.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...