Jump to content
Flirc Forums

Dealing with Interference. Options?


JayG
 Share

Recommended Posts

So I have 4 mini pcs running kodi/libreelec and have 4 flircs and matching remotes.   Three of them work fine, one didn't.  After a bunch of swapping, I realized they all worked except in the that 4th room (bedroom).   After killing all power to lights, fans, air purifiers, etc... I figured out it was the TV itself  that was royally confusing the flirc to a range of about 7 ft.   When the TV is off, I'll VNC into the kodi/libreelec/mini pc  from a laptop and watch the remote and flirc work flawlessly, but as soon as the TV is on, nothing.   I've tried putting the flirc in a box with a repeater and taping the box up completely with 3 layers of electrical tape to form an "IR seal".  Still nothing until the repeater is about 7 ft away.     I put the flirc into my laptop and debug the IR channel in the device log and see just tons of garbage with the remote control input not being registered until the laptop is about 7 ft away.    The TV is a 2016ish Sharp branded Roku TV in the USA market which I think might actually be a Hisense.      Could this be EMI messing with the flirc instead of excess IR?    Is there a knowledge base of TV/devices that cause interference with flirc that render the flirc unusable.     Short of buying a new TV for the bedroom, what other options should I attempt before giving up on this setup.   

Link to comment
Share on other sites

11 minutes ago, jason said:

Where is the flirc plugged into?

I've done both "directly into the mini pc's usb ports, tested with all ports two USB2 and two USB3" and with a Type A extender on all ports.   All results were the same, interference until about 7ft.

Link to comment
Share on other sites

18 minutes ago, jason said:

Where is the flirc plugged into?

Also tried electrical taping the IR repeater directly to the flirc with the other end of the repeater 4 ft away, but the same results until the flirc itself is about 7ft away from the TV that's seems to be causing the interference.  

Link to comment
Share on other sites

4 minutes ago, jason said:

When you record. Do so in another room. And then go to advanced and disable all the built in profiles

I actually recorded in a different room and loaded the same config onto all 4 flircs.  This worked well for the other rooms.  But in attempt to isolate the issue, I re-recorded in the problem room itself.   Same result.    Currently the flirc in the problem room is loaded with the known-good  config that was recorded in a different room.  

Link to comment
Share on other sites

2 minutes ago, jason said:

Can you post the config? How about a hub invetween that has a power adapter. If it’s emi, let’s isolate the grounds. 

I'll post both configs (known good and one that was recorded in the problem room) when I get home in a few hours.   I actually do not own a powered USB hub, but I can probably rig up something from spare parts to isolate the ground.      FWIW,  This 'interference' occurs when the flirc is in the mini PC and when the flirc is in my laptop running off battery.      I also took the whole mini PC with the flirc and hooked it up to the TV in the known good room and it worked flawlessly.   Oh yeah... thanks so much for the quick response.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...