Jump to content
Flirc Forums
CodaMan

Windows 10 Driver Problems

Recommended Posts

CodaMan    2

1) Had the Flirc software loaded on my Windows 8.1 machine and it worked fine, upgraded to Windows 10 and it STILL works.

 

2) Did NOT have Flirc program loaded on another Windows 8.1 machine, upgraded to Windows 10, installed Flirc program and it will NOT work.  When I check the device manager it says that there is a driver problem with the Flirc device.  If I start the Flirc program it does not show the device as connected and when I exit it tells me that the program is not working properly and forces a program shut down.

 

Anyone else having this problem or know how to correct the driver problem?

 

Can I obtain the Flirc drives so I can point Windows 10 to them?

 

Thanks in advance

Share this post


Link to post
Share on other sites
jason    141

100% confirmed. I just got my own copy of windows 10 yesterday and I will work on solving this over the weekend. I'm very sorry for the inconvenience.

The biggest lesson for me, is that I need to start signing up for developer access for windows and mac.

Thanks so much, hang in there.

 

I believe you can pair it on another machine and use it in windows 10 just fine, can you confirm?

 

Very Sincerely,

Jason

Share this post


Link to post
Share on other sites
CodaMan    2

OK.  I was able to get it working by right clicking the Flirc device in the Device Manager and select Update Driver Software.  Then select Browse My Computer and point it to Program Files (x86) > Flirc > Driver > usb_driver

 

All working good now.

Edited by CodaMan
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Kieran    3

Sorry for resurrecting an old thread, however I thought this was sort of related:
I recently (few months ago) upgraded my MS Surface Pro 3 to Win10.

I also have another SP3 that came with Win10 installed by MS.   I also have a Windows7 nano-pc (amd fusion e350 apu based nettop) on which I run Kodi and WMC, which is where I primarily use my FLIRC.

Recently, I tried to program the FLIRC on one of my surfaces (don't recall which one).  I installed the FLIRC software/gui on the surface and plugged the flirc into it.  I was able to program it normally.  However, when I then plugged the flirc back into the Win7 htpc box to use as I normally do, it wouldn't work.  

The solution was to load the FLIRC gui software onto the Win7 htpc box, program it there, and then it worked fine.  I know that in the past I had programmed the flirc on the Surface when it was running Win8.1.  So something changed with Win10.

I've got a decent work-around here, so I'm not complaining or requesting a fix, but I thought this might be a good FYI for you.

Share this post


Link to post
Share on other sites
xmai77    0

I recently purchased a flirc usb off Amazon.ca.  I can't seem to get it working on my Windows 10 32bit system. I've tried manual driver installation, wiping drivers with ghostbuster, and zadig.     

The flirc usb I have looked different from the one that's sold on the site. I'm guessing Amazon.ca sells an older model? Is this the problem?       

Share this post


Link to post
Share on other sites
jason    141

I recently purchased a flirc usb off Amazon.ca.  I can't seem to get it working on my Windows 10 32bit system. I've tried manual driver installation, wiping drivers with ghostbuster, and zadig.     

The flirc usb I have looked different from the one that's sold on the site. I'm guessing Amazon.ca sells an older model? Is this the problem?       

No, the two are currently virtually identical as far as features. I'll help figure this out. It's likely due to something I didn't catch. Please post a picture of your device manager when you have a moment.

Share this post


Link to post
Share on other sites
Sid    0

Jason,

I believe I'm having the same issue as the xmai77.

New FLIRC

Windows 10 Pro, 64 bit (clean install, albeit some time ago)

(Windows Insider Preview - Pro Build 14965.rs_prerelease.161104-1700)

Gigabyte GA-X58A-UD7 motherboard on a custom built desktop.

 

If you're able to solve it, I'd love to hear how! Otherwise, I'll try do the initial programming on a friends old WinXP laptop.

Share this post


Link to post
Share on other sites
jason    141

Fix posted, let me know if this did it, and then please PM me as well Sid, I'll give you a new one as a thank you for the patience and my apologies for the trouble.

Share this post


Link to post
Share on other sites
Sid    0

Fix posted, let me know if this did it, and then please PM me as well Sid, I'll give you a new one as a thank you for the patience and my apologies for the trouble.

Fixed! Works like a charm, you sir, are a gentleman and a scholar!

Share this post


Link to post
Share on other sites
jason    141

Okay, I posted another update which fixed another crashing issue. We're on v2.0.2 right now. This was with older generation devices.

Share this post


Link to post
Share on other sites
me1865    0

I have the same problem as Nismonx with a clean install of win 10 x64 enterprise. I used the v2.0.2 installer (with the 'old' FLIRC).

 

Edit 31-12-2016

Please give a response as I can not use the remote on my HTPC.

Edited by me1865
No reaction

Share this post


Link to post
Share on other sites
jason    141

I have the same problem as Nismonx with a clean install of win 10 x64 enterprise. I used the v2.0.2 installer (with the 'old' FLIRC).

 

Edit 31-12-2016

Please give a response as I can not use the remote on my HTPC.

Was fixed in v2.0.3, I just posted v2.0.4 which allows you to load a config from an older generation device to a new device. Please let me know if you are having problems. I haven't heard a complaint with v2.0.3 yet.

Share this post


Link to post
Share on other sites
me1865    0

Was fixed in v2.0.3, I just posted v2.0.4 which allows you to load a config from an older generation device to a new device. Please let me know if you are having problems. I haven't heard a complaint with v2.0.3 yet.

I have just tried 2.0.4 but with the same result, unfortunately. Full system freeze during the driver install. The driver does not install correctly (warning in the device manager) and the FLIRC software is not able to connect to the device.

Share this post


Link to post
Share on other sites
jason    141

I have just tried 2.0.4 but with the same result, unfortunately. Full system freeze during the driver install. The driver does not install correctly (warning in the device manager) and the FLIRC software is not able to connect to the device.

Do you have the new model? It uses no drivers. 

Share this post


Link to post
Share on other sites
jason    141

Thanks for the feedback. This solution does work. But I have to say that it is not a very elegant one.

The new flirc doesn't use drivers. One of the best features of the device.

This problem was by far the largest support isue with the first generation. 

Share this post


Link to post
Share on other sites
FranzCisco    0

Just bought a flirc dongle myself and couldn't get it running.

Using Windows10 x64. Already tried to use the zadig tool. I got the Device in my device manager as a libusbk Device, but the Flirc Software never changed the dialog to "connected". Tried with different Workstations and had the same problem on all devices.

When first plugged in and started flirc software it tried to upgrade the firmware. Software at some point didnt respond anymore (even after hours of waiting).
Any idea?

Share this post


Link to post
Share on other sites
jason    141

@FranzCisco, do you have the metal flirc or the plastic flirc?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×