Jump to content
Flirc Forums

Controlling VLC Media Player (under Windows)


Recommended Posts

Hello,

 

1. my understanding of Flirc is, that I plug in the stick into my Windows 7 PC, take e.g. the remote control from my TV and learn some keys of the remote control into the Flirc stick.  (The TV is a Display for the PC). Then I start VLC (a media player program for all types of movies) and play a movie. When I now press a key on the remote control from the TV, Flirc should recognize e.g. the stop key and pass it to VLC.However this doesn't work.

 

When I learn all number keys from 1 to 0 into Flirc and I start a simple Editor or open a Windows cmd window and press then the number keys on the remote control, this works and the numbers are written in the file edited resp. the cmd window.

 

Why does this not work for VLC?

 

(I have the GUI v1.2.6 installed and updated the firmware to v2.6.)

 

 

2. Is the intention of Flirc somthing totally differen? I read, that I should learn the keys into Flirc at my PC, unplug the stick and then add it to another unit, e.g. a media player or a dvd player.

 

 

Thank you for any answer.

 

pope5

Edited by pope5
Link to post
Share on other sites

Nope, that's exactly it and it's working. The idea is, if I had to do something custom which applications then had to support, then I'd have to wait for the application developers to integrate flirc support. However, if you mimic a keyboard, then flirc works with any application. All applications support keyboard strokes. So find the shortcuts you want to use to control VLC, and pair those with your remote. Does that make sense?

Link to post
Share on other sites

ok, now I found my mistake.

 

I selected in the GUI the Windows Media Keyboard. There is a stop key (filled squared rectangle) and a play key (filled arrow to the right). And my remote control, I use, also has two keys with those symbols. Therefore I paired them.

 

However VLC need the key "s" to stop playing. And therefore it didn't work.

 

Now I loaded the full keyboard, selected the "s" and paired it with the stop key on my remote control. And now I can stop the VLC playing.

 

And one more thing: when I want to pair a "z" with a key, I have to use the "y" key and not the z on a German keyboard! On German keyboards y and z are exchanged. This seems to be not respected by the GUI.

 

 

Thank you for your help

 

pope5

Link to post
Share on other sites

ok, now I found my mistake.

 

I selected in the GUI the Windows Media Keyboard. There is a stop key (filled squared rectangle) and a play key (filled arrow to the right). And my remote control, I use, also has two keys with those symbols. Therefore I paired them.

 

However VLC need the key "s" to stop playing. And therefore it didn't work.

 

Now I loaded the full keyboard, selected the "s" and paired it with the stop key on my remote control. And now I can stop the VLC playing.

 

And one more thing: when I want to pair a "z" with a key, I have to use the "y" key and not the z on a German keyboard! On German keyboards y and z are exchanged. This seems to be not respected by the GUI.

 

 

Thank you for your help

 

pope5

Yes, unfortunately, I don't have support for internationalization settings yet, but it's on the map. For now, just use a side by side comparison for the german keyboard ignoring what the key on my GUI says. 

 

That's exactly what you need to do, use the keyboard controller view in the GUI and manually do the pairing this way.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...