Jump to content
Flirc Forums

Flirc_util not functional due to dependency on libreadline 6


Recommended Posts

I just tried to set up the flirc_util library on my Raspberry Pi and when I try to run it I get an error saying "libreadline.so.6: cannot open shared file: No such file or directory". Running Debian 11.4. I tried to symlink libreadline 8 (the current version) to #6, but still got the same error.

Separately, I tried to build the SDK myself, but make was giving me an error about an unrecognized "-m64" option.

Any plan to release an updated version of the software, or how else to fix all this?

Link to comment
Share on other sites

The binaries available on the apt source provided by flirc are only available for ARM 32bit. This will work on the ARM 64bit architecture, but the libreadline dependency will not be installed by APT. I solved this by adding armhf to my architecture list, installing the 32bit version of libreadline, and linking it to libreadline.so.6 so flirc can find the dependency. Ideally flirc would release a binary for arm64 so it works with modern raspberry pi architectures...

sudo apt install curl gnupg
curl https://apt.fury.io/flirc/gpg.key | sudo apt-key add -
echo "deb [arch=armhf] https://apt.fury.io/flirc/ * *" | sudo tee /etc/apt/sources.list.d/fury.list
sudo apt install flirc
sudo dpkg --add-architecture armhf
sudo apt install libreadline8:armhf
cd /lib/arm-linux-gnueabihf/; sudo ln -s libreadline.so.8 libreadline.so.6

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...