Jump to content
Flirc Forums

Warning:Cannot open usb device on Linux


Recommended Posts

Hello all,


I just downloaded and installed the new GUI on a Windows 64-bit machine.  Flirc opens, updates firmware, button presses work great.  I then plugged the Flirc into its eventual home, running XBMCbuntu (Lubuntu 12.10).  When I run the Linux version of the Flirc software (also the newest GUI installed), it tells me the device is disconnected.  If I try to connect via the CLI, I get a constantly repeated message of "Warning: Cannot connect to USB device".  


If I lsusb, I can see the device (comes up as Clay Logic?  that's the only device other than the mouse and keyboard plugged in).  


The Flirc has always been more difficult to wrangle on the Linux box than Windows, but it was at least functioning before on the previous FW.  I have since downgraded to FW 1.0 and I am still getting the same errors about unable to connect to device.


Any thoughts?  I just got my Flirc recently so we have not been through too many changes to GUI/FW yet, but the convenience of the device (or so I am told) lead me to believe that this is the best option for my setup.  

Link to comment
Share on other sites

re-run as sudo


Or, you'll need a udev rule, create a file called 51-flirc.rules


put the following in the file:


SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", MODE="0666"


That is a bit extreme, every USB device becomes read/write accessible to all users, but honestly, it's absolutely stupid that you need root privileges to write to a usb device.

Link to comment
Share on other sites

Okay, now I am getting somewhere...


Running as sudo alone did not do the trick, but adding the udev rule got me most of the way up and running.  When running the GUI, I still periodically get disconnects that drop and then reconnect right away.  If I try to record a key, it tells me there is no more space.

Running the CLI, keys tells me that the list is empty, though most keys automatically register when pressed in the GUI (I am running a Harmony using the Flirc profile).  If I run space,  it will randomly insert "usb transfer failed, error code[-1] Input/Output error" but still give me the keys information (165 keys, 3 remaining, using 5500% memory?).  I also tried to record to see if it was picking up ghost signals, but it gives me an error that there is no space left on the device.  Initially in my front USB port it would then type an endless string of the character I was recording, without me pushing a button.  I switched the Flirc to the rear USB port and now I do not get the string, just the no space left on device error.  It seems that switching the port also got rid of the usb transfer failed errors when running space.  Hopefully most of that was just some ghost signals it was picking up.


Thanks for your great support on this site, I am usually able to fix my issues by searching through the forums but this time I felt I needed to reach out because I am a bit stumped.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...