Jump to content
Flirc Forums

Cannot install Flirc Gen 1 USB driver on Windows 10 & shows as Disconnectedin FLIRC App

Paul Tanner

Recommended Posts

Dear Sir/Madam,

I have been using a FLIRC Gen 1 to enable an old universal remote to control Kodi on my Raspberry Pii for a number of years. I have just replaced my controller with a One For All Essence remote and need to reprogram the FLIRC keys, which I haven't needed to do for a long time. I have connected the Flirc to a Windows 10 Home pc but device manager showed it could not  find the driver. I followed an older forum post to resolve (https://support.flirc.tv/hc/en-us/articles/200712548-Using-the-ZADIG-Utility) using ZADIG, which enabled me to install a working driver. However when I install the latest app it shows the FLIRC as being disconnected. I have tried on two different windows 10 PCs now and it is the same on both. Please can you assist? (NOTE: I'm not very techy so may need a more detail instructions or advise than most). Many thanks in advance.  

Link to comment
Share on other sites

  • 4 months later...

So the file Jason linked to above didn't work for me. It said I was missing a .dll. What I did was:

  1. Go to https://flirc.io/nightly/Flirc%20GUI/win/ and download the Flirc Setup Old.exe file at the very bottom of the list. (currently last modified 1/13/2021)
  2. Run the installer. It will take awhile to install the driver, but when finished the app should detect your gen 1 Flirc with 1.0 firmware.
  3. In the Flirc app go to Help >> Check for Updates... and install the latest version.
  4. Finally, after the latest version of the Flirc app is installed in the Flirc app go to File >> Advanced >> Force FW Upgrade.
  5. You should be done. My Gen 1 Flirc now has Firmware v3.11.0. 

I know Jason is the admin so he probably knows best, but the steps above are what worked for me.

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

Which latest version worked for you? 3.25.3-23 does not see flirc here, only the older version that I have does. This one got it up to 3.11 as well, but wants to upgrade to 3.12, which however never happens, and I´m wondering why this seems not to be happening at your end.

I´m asking because 3.11 seems pretty buggy here, more details at: 


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...