Jump to content
Flirc Forums

Ubuntu Minimal 12.10 - problems with resume


Recommended Posts

Hi guys,

I know there are opened topics on similar problems but somehow i feel mine is a bit different.

My understanding of technical stuff and English is limited to basics so if i miss understand something please just point me to solution.

Forgive me if this is a bit long to read but I feel that explaining in more details is crucial for finding good solution.

I got my flirc almost a year ago, bought it to control my XBMC machine. I used fw 1.

My Hw ( which can be relevant) is Zotac H55 ie + i3 500. Remote is Oneforall ES4

First I used it with Win7 - no problems sleep/wake worked 10+ (any button would wake system). I suffered problems with win drivers and hw acceleration so i moved from Win7.

Then i used it on Openelec system (beta 2) no problems there either 10+ (any button would wake system). Openelec has some problems with addons i use so i had to move once again...

XBMCbuntu 11.0 - no problems 10+ (any button would wake system). XBMCbuntu has no ability to change speed of keyboard and using remote was a problem (vol + / - , sub delay and different functions are to hard to control ) it just does not feel right.

Then I stumbled on this on XBMC forum "HOW-TO: Automated efficient (dedicated) XBMC installation on Ubuntu minimal 12.10".

This was great in terms of boot time, remote feel and whole XBMC experience. But this was the firs time a had problems with wake.

I quickly found this topic on flirc forum:

After reading i checked my setting and just made new udev rule. Flashed my fw to ver 6 and tried it out - worked like a charm but....

If i use ver 6 my flirc will wake my machine on any remote signal - from tv, sat or amp remote :(

Even bigger problem was that when woken from other signals, aside from "wake command" flirc is not present on system until it is plugged to a different port.

After that I reverted back to fw ver1, with udev rule still in place I am able to wake my system using remote, but after that flirc is not present in system (until it is plugged to a different port).

I found a program to reset usb but it does not work cause system does not see a device present to reset.

I did ask abut this in thread on xbmc forum and opened a topic on ask ubuntu forum but I got no answer to this day :(

I can't imagine this to be a flirc problem - cause it worked just fine on older versions of linux, but i am unable to solve this one on my own.

Hopefully someone here can help me out.

If you need more info just tell my what you need, i do not know almost anything abut linux so do not know where to start.

Thank you.


Link to comment
Share on other sites

Hi Chris,

Thank you anyway :)

I seem to have made some progress.

I disabled Legacy USB support in BIOS

- USB 2.0 Controler mode

- BIOS AHCI Hand-off

- Legacy USB1.1 HC Support

After that flirc is sometimes active after resume. :)

Further more i found how to unbind and bind back usb ports

(did found one like that before but it had typos so it did not work correctly, I did not notice that because I do not have sufficient Linux knowledge)

I found resume script that I am "moding" to my system and will test it for few days and get back with results.

All I can say it looks promising (did just one test so far though).

I woke my system with flirc and it was not present, but after entering:

echo -n "0000:00:1d.0" | tee /sys/bus/pci/drivers/uhci_hcd/unbind

echo -n "0000:00:1d.1" | tee /sys/bus/pci/drivers/uhci_hcd/unbind

echo -n "0000:00:1d.2" | tee /sys/bus/pci/drivers/uhci_hcd/unbind

echo -n "0000:00:1d.0" | tee /sys/bus/pci/drivers/uhci_hcd/bind

echo -n "0000:00:1d.1" | tee /sys/bus/pci/drivers/uhci_hcd/bind

echo -n "0000:00:1d.2" | tee /sys/bus/pci/drivers/uhci_hcd/bind

Flirc was present and working 10/10. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...