Jump to content
Flirc Forums

problems with flirc_util


Recommended Posts


I am having problems running command line flirc_util (v3.9.10) on macOS High Sierra. When I first tried running it I got:

"Library not loaded: /usr/local/lib/libhidapi.0.dylib"

I ran "brew install hidapi", and after that flirc_util would run and print the usage message. Unfortunately, when I tried any other command, like "flirc_util status", I was getting:

"device disconnected, can't run command"

Flirc itself works fine, and the GUI app works too. Could you point me to anything else I could try to make flirc_util work?

Thank you!

Link to comment
Share on other sites

Thanks for letting me know. I am using a non public version of hidapi, as there are several bugs that have been addressed in my copy.

Do the following; 

cd /Applications/Flirc.app/Contents/Resources

install_name_tool -change /usr/local/lib/libhidapi.0.dylib /Applications/Flirc.app/Contents/Frameworks/libhidapi.0.dylib flirc_util

For those without install_name_tool (mac developer plugins), updated flirc_util attached.

I'll issue an update shortly.

Sorry for the inconvenience.


Link to comment
Share on other sites

That command didn't help:

- - -

bash-3.2$ sudo install_name_tool -change /usr/local/lib/libhidapi.0.dylib /Applications/Flirc.app/Contents/Frameworks/libhidapi.0.dylib flirc_util


bash-3.2$ pwd


bash-3.2$ ./flirc_util status

device disconnected, can't run command

- - -

The version you linked to works, thank you!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...