Jump to content
Flirc Forums

Shield 2017 Non Pro and IR


Recommended Posts

I have a 2017 NVidia shield I just recently bought.  I did not get the pro version.  Now I need to be able to use IR to wake/sleep the box and do other things.  I bought a flirc since I heard it worked with the shield.  My issue is I cant program the flirc since I don't have the IR version.  How do I get this to work?  I use simplecontrol as my remote and it has the NVidia shield in its database, presumably the IR version so why couldn't the same commands be used on the flirc?  Am I screwed?  Would it work if someone were to give me a configuration I could load since I clearly cant create one with the shield remote?

Link to comment
Share on other sites

  • 2 weeks later...

I attached the configuration I came up with for my Inteset INT-422-3 and SHIELD TV 2017.  Because the USB ports are on the back, I also use an Electro 360 degree USB swivel to make the FLIRC face forward:


If the remote is already programed for the SHIELD, all you should have to do is load up the configuration attached into the FLIRC then plug it into the Shield and it should work.


-power button is a duplicate bound to OK because that's how you turn it on.  You still have to go to "Sleep Now" to turn it off.

-record, skip forward, skip backwards, guide, mute, and info don't work.  Fast forward and rewind should.


A better solution is apparently in the works but it's going to require a new remote (may be able to RMA for price of shipping) because FLIRC is getting a code directly.  I don't know though, I'm pretty confused.  All I know for sure is that the configuration is satisfactory.

NVIDIA - ShieldTV - 04918.fcfg

Edited by FordGT90Concept
Link to comment
Share on other sites

I will try that when i get home.  Are you familiar with the simple control ios app based remote system?  Do you have the IR version of the shield?

was able to use an old mce remote and program the keys to the flirc and then use the old mce remote to control the shield via IR, i dunno about power, i couldn't figure that one out.

So heres what i did, in simple control i added the nvidia shield via the simple blaster and used the test remote to learn the ir from the simple blaster into the flirc to control the shield but when i plugged it into the sheild when i was done it didnt respond to any of the simple control commands for the shield remote.  So worked for MCE remote, did not for simple control remote. 

I will try loading your configuration and seeing if that makes a difference.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...