Jump to content
Flirc Forums

Upgrade failed, Flirc now bricked?


Recommended Posts

This Flirc has been in use for some time withouth problems. Today I wanted to change some settings so I installed the latest Flirc software. After running the software, it automatically tried to update the firmware on the Flirc. Seconds later it showed a message like "upgrade failed". Since then, the Flirc device is no longer recognized.

The Flirc logfile is here: http://paste.ubuntu.com/23647032/
Note, I enabled logging only after the problem occured.

I tried connecting the Flirc to several PC's (Windows 10 and 7) but on all I got the same "Please connect Flirc" message.
The flirc bootloader is present in Device Manager when the Flirc is plugged in (under "libusbK USB Devices)

Is there anything that can be done to get the Flirc working again?

I completely removed the software and uninstalled the drivers, then reïnstalled the software and rebooted. After plugging in the Flirc, again the software tried to update the Flirc. On the bottom left there was a message like Bootldr v-1.-1.-1 (or something). The Flirc software now again says "Could not upgrade firmware. Contact support."



Edited by AllardSijm
Link to comment
Share on other sites


Hopefully this solution works for you AllardSijm.

1. Uninstall the GUI.

2. Move the Flirc to A DIFFERENT USB PORT then run GUI version 1.4.4. The firmware should automatically update to v3.8.

3. Remove the Flirc.

4. Reinstall the latest GUI (2.0.2 at time of writing).

5. Reinsert the Flirc into the original USB port.


Same thing has happened to me today on a Win 10 box with GUI 2.0.2 going from 3.6 from 3.8.

I have also tried reinstalling the GUI, and reinstalled the drivers with Zadig several times to no avail. I too see the bootloader in device manager.

At the moment the Flirc seems bricked.

EDIT: I have since tried the 1.4.4 GUI found HERE but it crashes as soon as the Flirc is plugged in.

Look forward to receiving word on this one.

Thanks, K22

Edited by K22
Link to comment
Share on other sites

Thank you K22, for your reply. I will try your solution later this day and will report back whether it worked for me also.

Your solution worked for me too. In the end I didn't need to uninstall the latest version, I ran the 1.4.4. executable while v2.0.2. was still installed. The earlier version upgraded the firmware succesfully and after that I could just run v.2.0.2. to start programming.

Again thank you for the solution!

Edited by AllardSijm
Link to comment
Share on other sites

  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...