Jump to content
Flirc Forums

some keys cannot be programmed


Recommended Posts

thank you for Flirc.  I've used your Flirc gen1 hardware for a few years and its worked great.
I'm been using it succesfully with a Tivo remote like this for a long time:
So I recently bought another Flirc from amazon:
Its a newer hardware version:
$ ./flirc_util.exe version
flirc_util version v1.3.6 [v1.3.6+]
  Firmware: v2.3 [34C4B78B]
it worked ok for a few weeks
but i was just having trouble with the interkey delay.  With version 1 HW, i could press the remote control buttons quickly, say <400ms between presses, and they would all register.
Now, sometimes it was taking 750ms wait b/w each press, regardless of the interkey delay.
I figured I'd update the firmware.
Flirc gui > File > Advanced > Force Firmware Upgrade
$ ./flirc_util.exe version
flirc_util version v1.3.6 [v1.3.6+]
  Firmware: v3.6 [0D58725B]
after upgrading i cleared the memory with the GUI and then i reprogrammed all the keys
It worked relatively OK again, but with same delay problems.
So I saved the new config file.  File > Save Configuration
Everything was good for 24 hours.
Today, the Flirc has suddenly scrambled its memory.  
7 or so of the 38 or so programmed keys now are linked to wrong keys (they trigger the arrow keys or space bar, instead of Fn keys)
Now I do:
File > Clear Configuration
File > Load Configuration.  from the known good backup i just made 24 hours ago.
Somehow, even with a known good configuration,  the problem persists
So I clear config again.
Try to program the problem keys one at a time.  Same problem.
The 7 keys: rew, ff, play, pause, skip back, skip forward, and slow can no longer be programmed.  
attempting to program those keys, even from a cleared config, doesnt work.   
all other keys are OK.  
I use Controllers > Full Keyboard to do all programming.
if i set the Tivo's big orange pause button to CTRL-P, what it ends up recording it as is "spacebar".  well, spacebar is what appears in the Flirc gui when the orange button is then pressed.  but if yet i see:

$ ./flirc_util.exe keys


$ ./flirc_util.exe keys


Recorded Keys:

Index  hash        key

-----  ---------   ---

    0  786ECA05    F7

    1  11E9CD1E    left_ctrl P

which appears to show it recorded correctly. yet flirc gui shows it as a spacebar key when the orange pause button is pressed and not the Left_ctrl P.  
likewise, pressing FF shows a left arrow key in flirc gui, not the F7 that the cmdline shows above.
yet 31 other keys can be programmed OK, just not this certain set of 7 tivo keys.
and these keys were working just 24 hours ago on this flirc HW.
also i get this USB error despite the GUI being closed and the ".exe" being specified

./flirc_util.exe version

flirc_util version v1.3.6 [v1.3.6+]

  Firmware: v3.6 [0D58725B]

Warning: cannot open USB device


Also I tried doing the recordings pointing up at the ceiling as i've read.  no difference.


I have tried removing and reinstalling Flirc via the Flirc.exe installer multiple times.


Not sure what else to try now.  


thanks for your help.  steve


Link to comment
Share on other sites

hi, thanks for fast reply.  


yesterday i did tried rotating it b/w different USB ports, but same result.


i did not change any keyboard layout in windows.


however-- the problem is now mostly solved, although with a strange glitch in the flirc gui



heres what i did:


after reading your message, i realized i could try plugging it into a mac.


i cleared the dongle via the mac gui (could not find any flirc_util inside the pkg)  then reloaded by good config that was saved from windows.


i tested it by watching the full keyboard gui inside of flirc and pressing buttons.


all seemed good.


now i plugged the flirc back into the PC.


surprisingly, the correct keys are now being sent to WMC as well as all other apps--  except for the flirc gui itself.


inside the actual flic gui using the full keyboard layout, it still shows the wrong keys pressed just for those 7 buttons. 


it appears the flirc app is not telling the truth about what keys it is receiving.

i have tested using the autohotkey keyboard spy to see what keys are pressed and all keys are all doing the right thing, just reported incorrectly by the flirc gui.   
i can live with it like this for now, or am willing to do further testing if it helps out the developers.  
Link to comment
Share on other sites

some further developments.


the flirc gui itself is still mis-reporting the keys as described above, which i can live with if its the only problem


but there was a new problem this morning.


there was a small window this morning (not sure how long) when the flirc dongle was not responding to any keyboard commands in any app... it wasnt just the flirc gui that was misbehaving.


i had been using WMC this morning all was working fine.  then suddenly, WMC would not respond to the remote at all.


i tried other apps, and sure enough, they were all no keyboard output from flirc.  it was like the flirc had totally stopped working.


i thought i'd have to reload everything and try again but instead i walked away.


i come back to it 15min later, and everything is surprisingly working OK,  in WMC and elsewhere.


so its now 2 different problems:

- TRANSIENT:  interruptions where flirc stops working across all apps and then somehow fixes itself.

- CONSTANT: flirc gui itself mis-reporting what keys are actually being pressed for a given IR


my version 1 hardware flirc from a a few years ago was really rock solid after getting it setup and i am using the same tivo remote as then.    not sure what else to try.  i am willing to try to downgrade to an earlier firmware if you think that could help.  or anything else.  thank you

Link to comment
Share on other sites

"- TRANSIENT:  interruptions where flirc stops working across all apps and then somehow fixes itself."

This could be because you have the GUI open. Please don't leave the GUI open, it's not required for normal operation, just pairing.


- CONSTANT: flirc gui itself mis-reporting what keys are actually being pressed for a given IR

This is probably because of your host operating system keyboard selection. I think this was mentioned previously. My GUI doesn't honor what you selected as your OS keyboard, it doesn't remap the keys. So if you are using an international keyboard, this will cause it too.

Link to comment
Share on other sites

Thank you jason.

Yes, I did have the GUI open simultaneously, so I won't do that any more.


the flirc gui misreporting issue:    i didnt change anything, but possibly something else did?  the thing is that the flirc gui was reporting correctly until i updated the firmware (at least, thats what it seemed to coincide with).  


right now i went to Control Panel > Language > Options and I see the Input Method is set to "US".  i presume that is correct?


the main problem right now...besides this more minor but strange gui quirk, is that i have been having lots of problems with long delays between each keypress.


earlier today i had to wait approximately 1.25 seconds between keypresses to flirc.  anything pressed sooner would not be recognized.  


now, for whatever reason i do not understand, it has fixed itself on its own, and i am now able to press keys at the rate of ~400ms spacing.


but this is not the first time i have seen this problem, and it part of why i upgraded the firmware in the first place.


right now i have interkey delay set to '4'.  i have tried various other settings with seemingly random results.


at this very moment, it is OK again, at about a 400ms minimum delay required between keypresses, which i can live with.  ideally, i would like to try to find a way to get it down to say ~200ms, if possible with this tivo remote, at least for the transport controls and the skip/back buttons, if possible.


but when it suddenly changes to ~1.2ms required between presses, it feels too laggy like things are broken...

Link to comment
Share on other sites

ok.  just after i wrote the above, the remote stopped working altogether.. no buttons working at all.


i quickly go the autohotkey to spy on whether any keyboard keys are being triggered or if its just WMC glitches.


i press all different keys on the remote... nothing reported in autohotkey at all.  like flirc totally dead.


suddenly, while i am in the midst of checking, i am now seeing responses inside autohotkey..  it appears flirc is working again


i quickly go back to WMC..  and sure enough, its working once again in WMC too.


the flirc gui was not opened during any of this.   and all options under Advanced were unchecked.

Link to comment
Share on other sites

i am no longer 100% confident that my last post was accurate when i said the flirc was totally dead.  it might have been, but i can't say for certain now. heres why.


this morning i attempted to use the flrc in WMC.   it appeared totally dead.  cursor would not move in any direction.  then i realized then the cursor had actually moved once when i first picked up the remote with its first button press.  but all subsquenet presses were not registering.   


so this time, what i thought was a dead flirc, was actually a case of the flirc now requiring an larger delay between each keypress than i had realized thereby continually blocking a subsequent keypresses as i was pushing too fast.  it seemingly required a 4 second delay between presses.  but now as i continue to test that number seems to be going down and now is ~750ms or so.


i am still fairly certain however that e last post was accurate in that the flirc totally stopped responding because i do not think i was continually pressing buttons between the time that i quit WMC and launched autohotkey's keyboard spy, at least 1 key should have registered in autohotkey

Link to comment
Share on other sites

about an hour later now, the flirc is for whatever reason more responsive again, responding to my keypresses approx every 400ms.


hopefully you can begin to see the type of erratic behavior i have been experiencing.



EDIT - a couple hours later, its back to fairly unusable. right now its requiring 1-2 seconds between keypresses.


EDIT - its now the evening... for the last several hours, flirc is not sending any keys whatsoever.  and as of right now, it is still completely unresponsive, 100% dead.   if theres anything i can do during these occasions to assist in debug please let me know.  thank you


EDIT - 30min later...now responding again


EDIT - maybe an hour later it stopped responding.  it never recovered.  


it is now 24 hours later and it is still completely non functional.  


i've just reverted to using the mouse for now, in case you want me to leave it in the state for debugging purposes...

Edited by steve111
Link to comment
Share on other sites

So currently its working again, but very poorly as i have to wait several seconds between keypresses.    


basically it will rotate between working poorly like this, to not working at all.


what do you suggest?


i have 3 flircs in total


the first was great, old, and i gave it away.


the 2 others i bought on amazon on the same day, presumably were identical hw.


one of them is the one that now went bad on me, whether this is hw or sw problem i dont know.


i've been holding off trying my other new flirc,  one as i didnt want any confounding variables.


i presume the unused one is still on the v2.3 firmware, the same firmware the bad originally came with.


do you want to email me an older or newer beta firmware or something?


do you want me to try the unused flirc?


if so, just put it in and reload my saved config?  or must i program it from scratch?


i really have had a great time with my original old flirc (v1 or so) and now i am very sorry i gave it away.  


i did not expect to have any trouble with the newer model flircs, especially when using my same remote.


i presume it is not possible to rollback the newer model flirc to an ancient flirc firmware as my original flirc had.   i am going to find out what the hw version / firmware version was on that old unit i had was


ok.  thanks for your help


EDIT:   heres the firmware of my 1st gen Flirc,  it was indeed running firmware V1.0.  Is there any way I can run V1.0 firmware on my newer flirc?

Firmware: v1.0 [020A0001]
Edited by steve111
Link to comment
Share on other sites

  • 3 weeks later...

Just wanted to follow up that the problem is SOLVED.


if anyone else has weird inconsistent problems:






there is NO FIRMWARE BUG.  It was 100% user error. 


i should have obviously tried that up front.


i usually do.


i think in this case what had fooled me was that


1) i had just changed batteries these batteries less than a month ago, so thought these were good.  apparently although they were new ,they were very crappy batteries.


2) the fact that i was (and still am) getting flirc gui mappings for certain keys showing different keys being pressed than what flirc actually fires.  apparently above i was told this is due to a changed keymapping but i dont know how/where to fix that


in any case, all is well.  thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...