Jump to content
Flirc Forums

New Flirc broken or Firmware Bug?


Recommended Posts



today i received my new Flirc from Amazon. Yeah!!! :D


But the big disappointment appears right after plugging the Dongle into the HTPC-Box. :mellow:  I'm not able to pair my own Keys, because Flirc-GUI pairs the keys itself!!! When i press the virtual key, e.g. '1' at the GUI, the key is immediately paired (i didn't press any key on the RC (-> One for All URC 7562)!). I tried this on a Linux and a Windows Box, the issue persists. After the unwanted pairing the virtual Key flickers green, just like the RC fires '1' rapidly. Checked this with a text editor where i can see a 'running 1'...


Is it possible, that the (or only my one?) Flirc is extremly sensitive against environmental/noisy light? When i cover the Dongle with my hand, this behavior of immediate pairing is gone; when i open my hand a little bit, the key pairs without any other action  :wacko:  :wacko:  :wacko:   ....I have no illuminations, computer case lights or others, that could disturb the flirc's IR-receiver, only low light.


After hours of playing around with it, googling, trying other settings....updated to the latest Firmware, clear config, switched Noise Canceler on/off, tried every Inter-Key Delay from 0-6....I'm really disappointed at this point, Flirc is unusable for me :angry:


Can anyone help please? Is this a normal behavior??? :blink:  Or is my Flirc broken or is this a Firmware bug?






My settings:


flirc_util version v1.2.6 [v1.2.6]
  Firmware: v2.6

  sleep detection:  Disabled
  noise canceler:   Enabled
  inter-key delay:  0
  state:            0
  builtin profiles: Enable

Memory Info:
  keys recorded:  6
  keys remaining: 163
  memory used:    4%

Recorded Keys:
Index  hash        key
-----  ---------   ---
    0  B75755AE    1
    1  7CCF14A    1
    2  74E60504    1
    3  154EC48F    1
    4  44354ECB    1
    5  A994C854    1



BTW: Recorded Keys count doesnt matter- problem persists :(

Link to comment
Share on other sites

  • 3 weeks later...

Ive had the same issue and currently my flirc is sitting on the side and i am making do with my pulse eight CEC adapter untill these issues are ironed out. I would say be patient, it will be figured out eventually! (Btw these symptons persist even with the upgrade. Im gonna give it a shot with my raspberry pi to see if its just on windows these symptons surface)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...