Jump to content
Flirc Forums

After a Period of time Flirc Repeatedly Stops working


Recommended Posts

I am running flirc on RASPBMC and its setup pretty well and initally works ok with my remote however I leave my Pi on much of the time and when I come back to it Flirc fails to respond. It does seem to take hours of being left.


XBMC is still working fine I can control it with the wifi App remote, but until I reboot XBMC flirc wont do anything.


My other USB device (Hard Drive) is fine and still seems awake and responding.


Any advice?



Link to comment
Share on other sites

  • 3 weeks later...

I think this might be a problem with power saving features on specific hardware or software - at least on Windows 8. Check USB power settings in device manager if there is something that can be switched to disable the feature. It may also be a setting in BIOS/UEFI.

Link to comment
Share on other sites

I had submitted a support request but thought I'd search here too.


I just picked up the flirc last week and got it working great, except for this issue. Running the 3.0 firmware.


With my configuration, I completely startup/shutdown my HTPC when I use it.


Almost every time my Win7 HTPC boots up, the flirc is not a listed device. I have to physically remove it from the USB slot and re-insert it, get the USB detected sound, and then it works as per normal until I start the HTPC next time.


I have tried multiple USB ports but no change.

Link to comment
Share on other sites

Same problem here. I can use it for a few hours with no problem. But after I get home from work, and not having used it since the night before, I have to disconnect my Flirc and reconnect it for it to work. This only started happening when I updated firmware to v3 and the software to latest version as well. I did this one after the other so no idea if any one of those caused it. My setup is below:


Windows 7 Pro x64


Flirc plugged into USB extension cable

Harmony remote


Is there a way to revert firmware to 2.x? I can't find the download.

Link to comment
Share on other sites

According to one of the developper, the problem is probably coming from the "sleep detection" option that is enable by default in the advanced option of the firmware 3.0


He is recommending to those who are having the problem to disable this option and let him know if the problem persists....


More details in this thread:






I have personnaly tried it on my flirc one hour ago and so far so good.....

Edited by CapHar
Link to comment
Share on other sites

I just noticed something that could be relevant. I was using my remote with Flirc, just browsing my Plex library, and decided to turn of my air conditioner. When I did so using the IR remote, I heard the USB disconnect sound come from my media center, which I found odd. I went back to the couch and my Flirc was no longer responding. I plugged it out and back in, all was working again. So i turned my AC off on and back off and same thing, Flirc is disconnected. IT seems as though Flirc is receiving a shutdown command from my AC remote. How can i disable this?!?!

Link to comment
Share on other sites

I'm dealing with the same issue.


Flirc stops working. Interestingly enough, the Flirc util reports 18 buttons programmed before and after it stops working, and after force upgrading the firmware (v3.1-v3.1,) the buttons begin to respond again-without me reprogramming them.


Is my flirc broken?


I've tried firmware 3.1, 3.0, 2.2. I have tried two different remotes, Two different computers and my OUYA. Same result. Interestingly enough, the flirc stops moving if I unplug it and replug it into the same usb port, or any usb port on any other computer.


I have disabled sleep detection. I am unable to disable Builtin Profiles. Once I disable builtin profiles, if I go back into the menus it reports as enabled.

Link to comment
Share on other sites

You should upgrade your firmware to v3.1 rc.2. The new upgrade fixed the problem for me.

Still having problems here on 3.1 final. upgraded from 3.0 last night with 1.2.8 firmware. 30 minutes or so and nonwake up. WIN install no provlems. android matricom mx2 has issues. Swap dongles and problem stays and remains clear on other.

Ps: and side note, regardless of issues, jason and crew -thanks for the product and subsequent work. Cant do without it even with a glitch or two. :)

Edited by Redwingsfansfc
  • Like 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...