Jump to content
Flirc Forums

flirc with ir repeater on ubuntu linux


Recommended Posts

Hello flirc community. I'm having some trouble with my flirc, and I'm posting here in desperation.


I purchased this IR repeater some time ago, and have been using it with great success with flirc on a windows vista machine running xbmc. I recently upgraded my htpc, and switched to linux in the process. I programmed the flirc first without the repeater, and it worked fine. I then moved the htpc into my media closet, cleared the configuraiton and programmed it again through the IR repeater. Flirc records the buttons, but refuses to repeat them. The repeater does still work on my 5.1 receiver.


I'm running Ubuntu 14.04, flirc firmware 1.2.6, and the latest flirc packages from the repository. If it matters flirc is plugged into the motherboard usb ports, not the front ones (I ran into that problem when I was running it on vista).


Please someone help me salvage this awesome device!



Link to comment
Share on other sites

When I go to use the remote after programming, it's spotty. Sometimes it recognizes the button press, but most other times it just sits silent, mocking me. It will also interpret the wrong button press sometimes.

Try the latest beta release. 


Link to comment
Share on other sites

sorry to be a pain, but when I run this I get

error while loading shared libraries: libXt.so.6: cannot open shared object file: No such file or directory

Are there any x64 binaries? I tried running this from the FAQ, but it doesn't work.

sudo apt-get install ia32-libs

edit: typed libraries, meant binaries... updated post accordingly.

Edited by fan_of_flirc
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...