Jump to content
Flirc Forums

Wrong mapping of keys


Recommended Posts

Hi there,

Just received my flirc and when I tried to set it up with my tv remote I found a weird bug that makes it unusable.


Actually, there are some keys shown on the flirc gui which are unmappable, for exemple when I try to link the "1" button of my remote with the "1" button on flirc gui, it becomes linked to the "7" button. And then whenever I press the 1 button on my remote, the 7 button on flirc gui becomes green.


None of the number is working (1 linked to 7, 5 linked to 9, 8 linked to 1, others linked to nothing) neither are the volume down (linked to 0) and volume up (linked to volume down).


I tried 3 different remotes and I always get the same result.



Also, even if when I press 1 on my remote the 7 turns green on flirc gui, when I press it while my mouse is on a text field it prints the "&" char which is the char under my 1 key on mac. Still, when on xbmc the mapping is not done correctly.


Hope you can help me!


Link to comment
Share on other sites

That's the problem. The GUI will appear to be a US keyboard, however, it's as if you were using a US keyboard on a mac set up as azerty. So disregard what my keys say, and use the azerty keys.


In other words, where A is on my GUI keyboard that's actually Q for you.


Let me know if that helps. There isn't much way around this right now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...