Jump to content
Flirc Forums

FW v2.4 does not repeat keys anymore


Recommended Posts

Hi all,


today I upgraded the FLIRC firmware from a very old v1.0 to the latest v2.4.

The very old FW worked fine paired with an Onkyo Remote for being used with XBMC.

I upgraded it because I was thinking that maybe I can wakeup my PC from S1 state (shutdown) with a new FW, since the old is not working (other wireless 2.4GHz keyboards are able to power up the PC with any key). The new FW behaves the same, no way to wakeup from shutdown (the AsRock FM2A88M+ Extreme4+ is a very new motherboard).


But now I have another problem: FLIRC does not repeat anymore the remote's keys pressed continuously like arrows down/up, volume up/down and so on. This is quite annoying.


Is it a problem of the new FW? The very old FW v1.0 was able to repeat correctly the keys.


In the v2.4 FW announcement is written:


  • fixed possible stuck key or endless repeats.

Is this modification the root cause of the new problem?


Where I can find older versions of the FW to check if it is a problem only of the v2.4?




Link to comment
Share on other sites

For sleep:


1. Go to the advanced tab

2. Enable sleep detect

3. record the wake button showed on the keyboard view


You can also try:


1. Record the wake/suspend key in the media center controller view


For the Repeat issue, try:


1. Go to advanced

2. Change the interkey delay to 3


Let me know if those work.

Link to comment
Share on other sites

Thanks for the reply:


i tried the interkey delay, and now it works with a value 4 or greater! So, first problem solved... Small question about it: Is it better to use the lowest working value or the highest one (4 or 6)?


For what concerns the Power ON: I would like to Power ON the PC from S5 State (Shutdown), not from S3 Sleep State. My PC is capable to do this because both a wired Keyboard/Mouse and a Wireless Keyboard+Touch (Rapoo) that works with a 2.4GHz protocol are able to Power ON the PC from S5 state with ANY KEY, also even by touching the Wireless Touch Pad that emulates a mouse pointer. Only FLIRC, that should send simple Keys like a keyboard, is not able to Power ON the System from S5 State: can I forget about this feature with FLIRC or it should work?


If I understood well, the "Enable Sleep detect" functionality switches OFF all the Keys while entering in Sleep and it will wake up only with the WAKE button specifically paired: this is not what I would like to do: the PC goes in Shutwdown and maybe with ANY Key (or just the Wake button only, if it works is fine for me) then starts to boot again.





Edited: I previously used S1 state for shutdown, but the right state i meant was S5.

Edited by miritellor
Link to comment
Share on other sites

Hi Jason,


this evening I tried your suggestion with a WAKE command registered and I enabled the "sleep detection" and... I can confirm that this command works also from the full shutdown!!! I tried it without big hope because on the previous posts on this forum I was able oonly to get confirmation about wakeup from sleep S3 state and never about S5 state (Shutdown).


Now I can confirm to everyone: with the new motherboards like the Asrock I have, FLIRC is able to completely Power ON and of course power OFF the PC!! This is perfect and lovely!


Last improvement to become an amazing product would be to be able to program the same key for both Power ON and Power OFF, the current proposal requires a very complex procedure to emulate this feature.


The post can be closed, now.

Very good job!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...