Jump to content
Flirc Forums
2oh1

Flirc sendings multiple commands on single button press

Recommended Posts

I have a first gen Flirc I've been using for years with a Mac and it's been flawless.  I recently switched to using it with a new Raspberry Pi 3 with the commands I'd recorded on my Mac.

Single key presses are sending the Pi multiple commands.  For example, the Pi sees "Command F1" as three separate commands:

# KEY_LEFTMETA

# KEY_LEFTMETA+KEY_F1

# KEY_F1

I don't understand why the Pi sees Command F1 as alt (meta), but the real issue for me is that when I press the assigned button on my remote, my Pi is receiving three separate commands.  Every time I press the assigned button on my remote, Alt opens the menu, my KEY_LEFTMETA+KEY_F1 command is executed, and my Pi also does an F1.

If I connect the same Flirc to my Mac, that same button press only executes a Command F1 (as intended).

It gets even crazier with more complicated key presses.

My Mac with Flirc sees Control+Option+Command+F1 as one event.  Control+Option+Command+F1

My Pi with the same Flirc sees Control+Option+Command+F1 as all of the following (at the end of each item, 1 represents a key press, 2 represents a key hold and 0 represents a key release.  Even the slightest click of a button generates all three):

# KEY_LEFTCTRL    1

# KEY_LEFTCTRL+KEY_LEFTALT    1

# KEY_LEFTCTRL+KEY_LEFTALT+KEY_LEFTMETA    1

# KEY_LEFTCTRL+KEY_LEFTALT+KEY_LEFTMETA+KEY_F12    1

# KEY_LEFTCTRL+KEY_LEFTALT+KEY_LEFTMETA+KEY_F12    2

# KEY_LEFTCTRL+KEY_LEFTALT+KEY_LEFTMETA+KEY_F12    2

# KEY_LEFTALT+KEY_F12+KEY_LEFTMETA+KEY_LEFTCTRL    0

# KEY_F12+KEY_LEFTMETA+KEY_LEFTALT    0

# KEY_F12+KEY_LEFTMETA    0

# KEY_F12    0

Any idea what's going on here and how to fix it?

I'm using a Sony universal remote, but I've tested this with other remotes and I get the same result: my Mac sees the one command I've programmed whereas my Pi sees each individual key press as a unique event.

Share this post


Link to post
Share on other sites

Check advanced settings in GUI. You probably have sequence modifiers option enabled. If yes, disable it.

Share this post


Link to post
Share on other sites

It's also probably the keyrepeat settings in linux. It's on too high. The OS Handles key repeats.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...