Jump to content
Flirc Forums

Flirc has worked fine for years, stopped today


Recommended Posts

I've got my Flirc connected to a raspberry pi 2 ( it used to be connected to a Pi 1 but I upgraded) everythings been working great on both pi's for over a year. Then today for no reason, none of the keypresses from my Harmony One work on the flirc at all. The soundbar and the tv commands still work.

I'm running the newest version of Kodi, just updated a few days ago or so, and things have been fine.

I've unplugged it connected it to my ubuntu box and updated the firmware, all the keypresses are still seen by the flirc according to the GUI. I'm not sure where I can look on the pi to see what's going on?

Link to comment
Share on other sites

The pi seems to see it just fine but still no keypresses registered


 1907.263360] usb 1-1.3: New USB device found, idVendor=20a0, idProduct=0001
[ 1907.263398] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1907.263415] usb 1-1.3: Product: flirc
[ 1907.263431] usb 1-1.3: Manufacturer: flirc.tv
[ 1907.281441] input: flirc.tv flirc as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0/0003:20A0:0001.0004/input/input3
[ 1907.335095] hid-generic 0003:20A0:0001.0004: input,hidraw0: USB HID v1.01 Keyboard [flirc.tv flirc] on usb-3f980000.usb-1.3/input0

Link to comment
Share on other sites

Jason, I connected it to my laptop and ran through reprogramming all the buttons on the remote, on the laptop it looks like everything is identified and working just fine. I rebooted my pi a few times and moved the flircs physical location. I also hooked up a keyboard , the flirc is picking up some keypresses when connected to the pi but not .. For example, I have to push play like 10 times to get it to play once. It's really odd because like i said it's been working just perfectly. I did update kodi recently but I'd expect I'm not the only person who's ever done that.


One really weird thing I noticed is if I touch the flirc it's like it acts like someone is pushing the back button over and over again.. I've tried all the usb ports, and a usb extension cable.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...