Jump to content
Flirc Forums

flirc_util bug


Recommended Posts

Just bought a Gen 2, and after installing the software I tried to use the command line utility and found that there seems to be a bug in how the command line is parsed.  Every time I try to use the utility, no matter what I put after the executable name I receive the same error message:

  • [E] lib/libcmds/cmds.c run_cmd(275): could not find command 'flirc_util'

Looks like it is considering the name of the executable as the parameter.  I double-checked by renaming the executable to 'help.exe', and sure enough I got the output I would have expected from 'flirc_util help'.

I renamed it to 'version.exe' and I appear to have version 3.25.3-16-g28e8a01+.  I'm running Windows 10.

Is this something that can be looked at for the next software release?  Alternatively, am I being very thick-headed and doing something amazingly wrong?


Edited by LewisPattJr
Forgot to specify my OS.
Link to comment
Share on other sites

  • 3 weeks later...

Finally found a work-around.

Apparently the first section of the command line is disregarded and not interpreted as a command if and only if it equals flirc_util.exe.  I was using flirc_util <command>, not flirc_util.exe <command>.

Everything works exactly as expected when including the .exe extension.

Maybe this could eventually be adjusted to handle both cases (with and without the .exe extension)?  Just a suggestion.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...